Unable to update Bib Source in MARC Edit screen

Bug #1843599 reported by Christine Morgan
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.2
Undecided
Unassigned
3.3
Medium
Unassigned

Bug Description

In MARC Edit, in either the full editor or the flat text editor, if you select a new bib source from the drop down menu and click Save, the "Successfully updated record" confirmation appears in the lower right. The value in the drop down then flips back to the original value. The confirmation then disappears and new value that was selected is not saved.

To reproduce:
1. Pull up a MARC record in the MARC Edit tab.
2. Note the value in the Bib Source drop down.
3. Select a new source from the drop down.
4. Click Save.
5. Watch the value you selected revert back to the original setting.

Observed in 3.2.8 and 3.3.3.

Revision history for this message
Meg Stroup (mstroup) wrote :

I am not able to reproduce this on our current 3.1.13 client. However, I am able to reproduce it on the MOBIUS public demo server (3.3.3).

tags: added: marc
Revision history for this message
Garry Collum (gcollum) wrote :

Confirmed in current master and in 3.2.7.

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Christine Morgan (cmorgan-z) wrote :

This did work in 3.2.4.

tags: added: regression
Revision history for this message
Christine Morgan (cmorgan-z) wrote :

May be related to Bug 1845241

Changed in evergreen:
milestone: none → 3.4-beta2
Galen Charlton (gmc)
Changed in evergreen:
milestone: 3.4-beta2 → 3.4.1
Changed in evergreen:
milestone: 3.4.1 → 3.4.2
Revision history for this message
Galen Charlton (gmc) wrote :

Noting that the patch for bug 1693580 appears to be the cause of the regression. Among other things, it switched the API used for saving bib records from PCRUD to open-ils.cat methods, which is fine, but open-ils.cat.biblio.record.marc.replace and open-ils.cat.biblio.record.xml.create expect the source to be passed in by _name_, not ID.

Changed in evergreen:
importance: Undecided → Medium
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

A patch is now available in working/user/gmcharlt/lp1843599_fix_bib_source_editing / https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1843599_fix_bib_source_editing

tags: added: pullrequest
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Revision history for this message
Rogan Hamby (rogan-hamby) wrote :

works as expected, sign off at user/rogan/lp1843599_cant_update_bib_source

tags: added: signedoff
Revision history for this message
Jason Etheridge (phasefx) wrote :

Thanks Galen, Rogan! Works for me as well; pushed to master. Testing 3.3 next...

Changed in evergreen:
assignee: nobody → Jason Etheridge (phasefx)
status: Confirmed → Fix Committed
assignee: Jason Etheridge (phasefx) → nobody
Revision history for this message
Jason Etheridge (phasefx) wrote :

Pushed to rel_3_3

Revision history for this message
Jason Etheridge (phasefx) wrote :

And pushed to rel_3_4!

Changed in evergreen:
status: Fix Committed → Fix Released
Revision history for this message
Rosie Le Faive (rlefaive) wrote :

This is happening now (on 3.4.2) if I edit the name of a bibsource (in the database). Now I cannot change the bib source to the newly edited one. If the bibsource is being passed by name not by id, then what level of reboot is required after changing the name of a bibsource?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers