New Vandelay Filter Checkboxes have no effect on Inspect Queue screen

Bug #1842765 reported by tji@sitka.bclibraries.ca
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
3.3
Low
Unassigned
3.4
Low
Unassigned

Bug Description

EG 3.3

The Record with Matches, Non-imported Records and Records with Imported Errors checkboxes on Inspect Queue screen have effects. No response.

tags: added: angular vandelay
Changed in evergreen:
milestone: none → 3.4-beta2
Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

On a 3.3.3 server, I created a MARC file containing a mix of matching and non-matching records and attempted to import it (specifying a Record Match Set and Merge Profile, but no other options). I navigated to the queue and it showed 1 record with 2 matches and 2 records with 0 matches. When I checked the "Records With Matches" checkbox I got this console error:

GridToolbarComponent.html:20 ERROR TypeError: _v.context.$implicit.onChange is not a function
at Object.eval [as handleEvent] (GridToolbarComponent.html:22)
at handleEvent (core.js:23106)
at callWithDebugContext (core.js:24176)
at Object.debugHandleEvent [as handleEvent] (core.js:23903)
at dispatchEvent (core.js:20555)
at core.js:21002
at HTMLInputElement.<anonymous> (platform-browser.js:993)
at ZoneDelegate.push../node_modules/zone.js/dist/zone.js.ZoneDelegate.invokeTask (zone.js:423)
at Object.onInvokeTask (core.js:17289)
at ZoneDelegate.push../node_modules/zone.js/dist/zone.js.ZoneDelegate.invokeTask (zone.js:422)

This error message was repeated in the console whenever I checked or unchecked any of the Records With Matches, Non-Imported Records, or Records with Import Errors checkboxes.

Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

I am unable to replicate this on EG 3.4 beta2. The issue appears to be specific to 3.3.

no longer affects: evergreen/3.3
Changed in evergreen:
milestone: 3.4-beta2 → 3.3.5
status: New → Confirmed
Galen Charlton (gmc)
Changed in evergreen:
milestone: 3.3.5 → 3.4.1
no longer affects: evergreen/3.3
Changed in evergreen:
milestone: 3.4.1 → 3.3.5
Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

Working branch user/jeffdavis/lp1842765-inspect-queue-checkboxes has a potential fix:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeffdavis/lp1842765-inspect-queue-checkboxes

The branch is based on rel_3_3 because the issue only affects 3.3. The fix slightly modifies the grid toolbar component, so we should ensure that it doesn't break other grid UIs.

tags: added: pullrequest
Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

I have looked at the other places where the eg-grid-toolbar-checkbox component is used in 3.3, and all of the following seem to work just fine with the fix applied:

- Vandelay > Inspect Queue > View Import Items: Limit to Import Failures
- Experimental Staff Catalog > View Holds: Pre-Fetch All Holds
- Experimental Staff Catalog > Holdings View: Show Volumes, Show Copies, Show Empty Volumes, Show Empty Libs

This is in addition to the Inspect Queue filter checkboxes. So I think the fix resolves the issue without breaking anything else.

Changed in evergreen:
importance: Undecided → Low
Changed in evergreen:
milestone: 3.3.5 → 3.4.2
Changed in evergreen:
milestone: 3.4.2 → 3.4.3
Changed in evergreen:
milestone: 3.4.3 → 3.5.0
Changed in evergreen:
milestone: 3.5.0 → 3.5.1
Changed in evergreen:
milestone: 3.5.1 → 3.5.2
Revision history for this message
Galen Charlton (gmc) wrote :

Now moot (and marked as duplicate) now the 3.3 is no longer under community support.

Changed in evergreen:
status: Confirmed → Won't Fix
status: Won't Fix → Invalid
tags: removed: pullrequest
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers