Apply button in Patron Bill History screen is in a confusing location

Bug #1841089 reported by Jane Sandberg
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Low
Unassigned
3.1
Fix Released
Low
Unassigned
3.2
Fix Released
Low
Unassigned
3.4
Fix Released
Low
Unassigned

Bug Description

The apply button in the Patron Bill History screen is located before the two datepickers (screenshot attached). In most forms, the apply/submit button is placed *after* form fields. This has led our staff to completely miss that there is an Apply button at all.

A better UX would be to place the apply button after the datepickers, in the flow that users will be more accustomed to. A quick glance suggests that this could be accomplished by rearranging some lines in this file: https://github.com/evergreen-library-system/Evergreen/blob/master/Open-ILS/src/templates/staff/circ/patron/t_bill_history.tt2

An even better UX would be to remove the apply button completely, since it is an extra step -- and refresh the grid every time the user selects a new date.

Revision history for this message
Terran McCanna (tmccanna) wrote :

+1 to refreshing the grid automatically.

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Dan Briem (dbriem) wrote :

I tested this on 3.3.2. I can see how someone might not see the apply button and I noticed invalid date ranges are possible.

This is a potential patch for testing that eliminates the apply button and watches the dates. If they are valid date objects in a valid date range the new date range is applied and the grid refreshes. If the start date > finish date they are set equal to each other to force a valid date range.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbriem/lp1841089_remove_bill_history_apply_btn

tags: added: pullrequest
Michele Morgan (mmorgan)
Changed in evergreen:
milestone: none → 3.3.4
Revision history for this message
Jane Sandberg (sandbergja) wrote :

This works well for me. Thanks, Dan! Sign off branch here: user/sandbergja/lp1841089_remove_bill_history_apply_btn_signoff

tags: added: billing signedoff
removed: bills
Changed in evergreen:
milestone: 3.3.4 → 3.3.5
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed all the way to rel_3_1. Thanks, Dan and Jane!

Changed in evergreen:
importance: Undecided → Low
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers