Tab for Preferred Name not keyboard accessible

Bug #1840329 reported by Tiffany Little
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.4
Medium
Unassigned

Bug Description

Found during the webclient accessibility audit.

The tab/link for Preferred Name in the Register Patron screen is not able to receive keyboard focus. If you try to tab through the form, you can't focus on the Preferred Name.

See: https://wiki.evergreen-ils.org/doku.php?id=accessibility:webclient_audit

See also: https://www.w3.org/WAI/WCAG21/quickref/#keyboard

Revision history for this message
Eva Cerninakova (ece) wrote :

Confimed in Evergreen 3.3.2
(Open-ILS/src/templates/staff/circ/patron/t_edit.tt2:226)

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Mike Risher (mrisher) wrote :
tags: added: pullrequest
Revision history for this message
Ruth Frasur (rfrasur) wrote :

I have tested this code and consent to signing off on it with my name, rfrasur, and my email address, <email address hidden>.

Galen Charlton (gmc)
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
importance: Undecided → Medium
Revision history for this message
Galen Charlton (gmc) wrote :

Works for me. Pushed to master, rel_3_5, and rel_3_4. Thanks, Mike and Ruth!

Changed in evergreen:
milestone: none → 3.5.2
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers