angular eg-grid should allow patron barcode to be clickable

Bug #1839548 reported by Andrea Neiman
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned
3.3
Wishlist
Unassigned

Bug Description

Masterish (3.3+)

In the experimental staff catalog, the new bib records holds display includes a patron barcode column.

It would be a nice enhancement if this column could be hyperlinked & open the patron in a new tab.

Lynn Floyd (lfloyd)
Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Fix pushed:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1839548-ang-cat-holds-bc-link

Included in the commit is a fix to how the copy barcode URL was generated -- it was not correctly including the copy ID in the URL.

This can likely be back-ported to 3.3.

Changed in evergreen:
milestone: none → 3.4-beta1
tags: added: holds pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Chris Sharp (chrissharp123) wrote :

Works for me! Pushed to master and rel_3_3. Thanks, Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Galen Charlton (gmc)
Changed in evergreen:
importance: Undecided → Wishlist
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers