Login page missing a h1 heading

Bug #1839365 reported by Tiffany Little on 2019-08-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
3.3
Undecided
Unassigned
3.4
Low
Unassigned

Bug Description

The login page has text that resembles a heading but is not marked as such. The "Sign In" text should be wrapped in <h1> tags. This will help with screen reader and keyboard-only navigation.

<legend>Sign In</legend>

See: https://www.w3.org/WAI/WCAG21/quickref/?showtechniques=331#headings-and-labels

See also: https://wiki.evergreen-ils.org/doku.php?id=accessibility:webclient_audit

Eva Cerninakova (ece) wrote :

Open-ILS/src/templates/staff/t_login.tt2:6

Changed in evergreen:
status: New → Confirmed
tags: added: bitesize
Shula Link (slink-g) on 2019-10-08
Changed in evergreen:
assignee: nobody → Sam Link (slink-g)
Shula Link (slink-g) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Sam Link (slink-g) → nobody
Terran McCanna (tmccanna) wrote :

Hi Sam,

The commit you pushed includes deletes to two files that don't look like they should be included. Can you please rebase?

tags: added: needs-rebase
removed: pullrequest
tags: added: needsrepatch
removed: needs-rebase
Shula Link (slink-g) wrote :

Rebased and pushed back up. Hopefully I did that right.

Shula Link (slink-g) wrote :

Okay, now it's definitely rebased and pushed back up without the mystery deleted files.

Terran McCanna (tmccanna) wrote :

Thanks, Sam!

Normally h1 and legend wouldn't be nested like this, but since it's arguably both a page title and a form title, and it doesn't appear to break anything to have them nested, I'm okay with it. If anyone else would rather avoid that and just use one, I would opt for the h1 only as it's more appropriate for accessibility needs.

My sign-off patch:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mccanna/lp1839365_login_page_missing_h1_header_signoff

tags: added: pullrequest signedoff
removed: needsrepatch
Michele Morgan (mmorgan) on 2020-02-03
Changed in evergreen:
milestone: none → 3.5-alpha
Michele Morgan (mmorgan) on 2020-05-12
Changed in evergreen:
milestone: 3.5-beta → 3.5.0
Changed in evergreen:
milestone: 3.5.0 → 3.5.1
Changed in evergreen:
milestone: 3.5.1 → 3.5.2
Galen Charlton (gmc) on 2020-08-13
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_5, and rel_3_4. Thanks, Shula and Terran!

Per https://stackoverflow.com/questions/45362950/header-or-legend, the fieldset could probably be taken out entirely, along with the legend tag, but that can be the subject of another patch.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
importance: Undecided → Low
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers