Add record to shared bucket from embedded catalog

Bug #1837802 reported by Jane Sandberg
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Currently, there is no way to add a search result in the embedded OPAC to a shared record bucket. It would be very helpful to allow this for situations in which several staff members are collaborating on one bucket.

Elaine Hardy (ehardy)
Changed in evergreen:
status: New → Confirmed
Changed in evergreen:
importance: Undecided → Wishlist
Revision history for this message
Meg Stroup (mstroup) wrote :

I agree that this would be very helpful.

Revision history for this message
Jonathan Moore (jonathanmoore) wrote :

This would be very, very useful. We want to use shared record buckets to keep track of MARC errors. Having this bug fixed would make it much more easy for multiple users to add to the same bucket.

Revision history for this message
Elaine Hardy (ehardy) wrote :

You can now add bib records in OPAC search list and results to a basket and from the basket to a bucket. Have you tried that

Revision history for this message
Jane Sandberg (sandbej) wrote :

Elaine: we have, thanks for the suggestion. Unfortunately, that only gives two options:
1) Adding to a bucket owned by the signed-in user.
2) Adding to a new bucket, also owned by the signed-in user.

No way to add to somebody else's shared bucket.

Jane Sandberg (sandbej)
Changed in evergreen:
assignee: nobody → Jane Sandberg (sandbej)
Revision history for this message
Jane Sandberg (sandbej) wrote :

Here is a branch implementing this in the Angular catalog: user/sandbergja/lp1837802_add_records_to_shared_bucket_from_catalog

Here is a link: https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1837802_add_records_to_shared_bucket_from_catalog

A few notes:
* This applies to the Angular catalog *only*, since I see that as the future. At the very least, it provides a treat for catalogers who use the Angular catalog.
* I turned the "Add to bucket" interface into a tabbed interface, since it was collecting a lot of options. Once we move to Angular 9, this code will have to migrate from the deprecated ngb-tabset.
* I also added a confirmation for adding to the shared bucket, since it is easy enough to mistype an ID number.

Here are some testing notes from the commit message:

To test:
1) As User A, create a bucket.
2) As User B, search in the Staff Catalog, and add some items to your
basket.
3) As User B, click Basket Actions, and choose add Basket to Bucket
4) Click on the "Shared Bucket" tab and enter the id of User A's bucket

Some potential scenarios to test:
* Trying to add to a bucket that does not exist
* Trying to add to an unshared bucket when User B does not have the
VIEW_CONTAINER permission
* Trying to add to existing and new buckets as before

tags: added: pullrequest
tags: added: staffcatalog
Jane Sandberg (sandbej)
Changed in evergreen:
assignee: Jane Sandberg (sandbej) → nobody
Revision history for this message
Terran McCanna (tmccanna) wrote :
tags: added: signedoff
Galen Charlton (gmc)
Changed in evergreen:
milestone: none → 3.6-beta
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master for inclusion in 3.6, along with a follow-up to switch to ngbNav and a follow-up adding release notes. Thanks, Jane and Terran!

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers