Angular org unit proximity adjustment admin interface does not display rows

Bug #1837656 reported by Galen Charlton
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.3
Medium
Unassigned
3.4
Medium
Unassigned

Bug Description

The auto-magic Angular org unit proximity adjustment interface includes a filter on hold request library. However, since that column is can be null but the OU selector always specifies a list of at least one OU, the interface will never display rows where the hold request library is not set.

That admin interface should either:

- have no OU filter widget at all
- have an OU filter widget but also offer a way to specify that no filter at all should be applied
- in conjunction with the previous option, allow the user to specify which OU column in the proximity adjustment table to filter on.

Grid column filters may well be sufficient for this.

Evergreen 3.3+

Galen Charlton (gmc)
Changed in evergreen:
milestone: none → 3.3.3
importance: Undecided → Medium
tags: added: angular
Changed in evergreen:
status: New → Confirmed
Revision history for this message
Bill Erickson (berick) wrote :

I have a commit in a working branch that allows the admin UI's to hide and disable the org filter. Locating...

Revision history for this message
Bill Erickson (berick) wrote :

From the code for bug #1837059 :

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=613f386defa37fed9789ea794b138387de1f2053

I had the same issue with the auto-magic hold_matrix_matchpoint UI.

Example passing the new flag:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=780402c00d728281f9bc87858a5322044abcda90#patch4

Note making it possible to pass a different org unit field to act as the basis for the org filter would also be similarly do-able, since the basic admin page already supports it as an Input.

Revision history for this message
Bill Erickson (berick) wrote :

Fix pushed:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1837656-org-prox-admin-grid-fix

From the commit: ---

Disable the org unit filter for the auto-generated org unit proximity adjustment admin page so that it does not automatically filter the grid by any of the org unit fields.

Modify the IDL to indicate that the 'pos' field on the org unit proximity adjustment class is required.

To test:

1. Navigate to /eg2/staff/admin/server/actor/org_unit_proximity_adjustment
2. Create an adjustment if none exist.
3. Confirm the 'Position' field is now required.
4. Confirm new adjustment row appears in the grid after it's created.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 3.3.3 → 3.3.4
tags: added: holds
Changed in evergreen:
milestone: 3.3.4 → 3.3.5
Changed in evergreen:
milestone: 3.3.5 → 3.4.2
Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks, Bill. It works well for me! Signoff here: user/sandbergja/lp1837656-org-prox-admin-grid-fix-signoff

Just a note that backporting to 3.3 will take a little more work, since the disableOrgFilter flag only appears in 3.4 and above.

tags: added: signedoff
Changed in evergreen:
milestone: 3.4.2 → 3.4.3
Changed in evergreen:
milestone: 3.4.3 → 3.5.0
Revision history for this message
Bill Erickson (berick) wrote :

Merged to master, rel_3_5 and rel_3_4. I have left 3.3 unmerged.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers