Port Local Administration main page to Angular

Bug #1837059 reported by Bill Erickson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Evergreen 3.3

Another Angular port... This time it's the Administration => Local Administration main page and a handful of trivially ported admin pages.

Branch in progress shows these UI's as portable with only minor tweaking:

actor/address_alert
config/barcode_completion
actor/copy_alert_suppress
asset/copy_location
asset/copy_tag
permission/grp_penalty_threshold
config/hold_matrix_matchpoint
config/non_cataloged_type
rating/badge

Remaining links will continue to point to their existing AngJS, Dojo, etc. pages for now.

Branch en route.

Revision history for this message
Bill Erickson (berick) wrote :

Changes including grid config workstation settings pushed:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1837059-angular-local-admin

A 3rd commit is also added to support passing the "disableOrgFilter" input through the basic-admin-page component to the admin-page component via the route (similar to passing readonlyFields).

tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Galen Charlton (gmc)
Changed in evergreen:
importance: Undecided → Wishlist
status: New → Confirmed
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

I've reviewed the patch and confirm that the Local Admin page includes everything and that the new Angular admin interfaces. However, I do see a documentation/usability regression: the Angular address alerts page doesn't have the help text that the Dojo version has, and in this case I think it's needed.

Maybe teach BasicAdminPageComponent how to accept a template for additional help text to display about the table?

Revision history for this message
Bill Erickson (berick) wrote :

Thanks, Galen. I think a BasicAdminPageComponent help-text addition can be arranged.

Bill Erickson (berick)
Changed in evergreen:
assignee: Galen Charlton (gmc) → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Pushed commit implementing the help template addition for the admin page builder, plus a new address alert component which invokes the admin builder with help text.

Note the address alert component was necessary since the help template needed a parent component.

Rebased to master.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1837059-angular-local-admin

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Galen Charlton (gmc) wrote :

Thanks for the additions, Bill. I've signed off and added a couple small follow-ups; branch is working/user/gmcharlt/lp1837059_signoff.

tags: added: signedoff
Revision history for this message
Galen Charlton (gmc) wrote :

And pushed to master for inclusion in 3.4. Thanks, Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Galen Charlton (gmc)
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers