Preloaded Audio Search / Icon format

Bug #1835736 reported by Rogan Hamby on 2019-07-08
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Wishlist.

I'm seeing a number of libraries need a new format to support devices that are mostly variants of MP3 players (e.g. Playaways). A common solution is to create a format called something like Preloaded Audio and use the item type of 'i' and item form of 'q'.

Elaine Hardy (ehardy) wrote :

We created one named Audio with Player and have an icon of headphones with a wavy line between the earpieces.

Changed in evergreen:
assignee: nobody → Rogan Hamby (rogan-hamby)
Janet Schrader (jschrader) wrote :

I discovered if I use the item type 'a' for print and the item form 'q' with no other criteria I can create a format for Audio Enabled Book. This is not the same as our 'Book' filter as that has criteria to distinguish it from microform, large print, braille, etc. It is a very basic filter.
The audio-enabled book is not the same as an MP3 player for our libraries because it physically is a book.

I tested the Audio Enabled Book filter and it works but I still want the Book icon to display so these items can be searched either way. It seems the Audio Enabled Book filter is preventing the Book icon from displaying.

I still prefer to use item type 'a' for print and 347 subfield 3 for this filter but cannot figure out how to create the record attribute for 347 $b.

I also removed item form 'q' from our E-book filter as it was making the Wonderbooks audio-enabled books show as e-books due to the 'q' in the 006.

Janet

Rogan Hamby (rogan-hamby) wrote :

There are a lot of ways that we could go but I've seen a number of Evergreen institutions settle independently on this common form so I'm going to go ahead and throw this out.

user/rogan/lp1835736_preloaded_audio

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=2faa5b8945dc76267f0d110e312ceb5e4c03c48e

tags: added: pullrequest
Janet Schrader (jschrader) wrote :

CWMARS already created a filter for "Digital Media Player". We've had this for several years.

Direct electronic AND Audiobooks and Playaway AND NOT 1.4 m. per second
item_type=i AND item_form=q AND NOT sr_format=f

The audio-enabled books have item_type=a and we don't consider these pre-loaded audio, a variant of MP3 players.

Rogan, how would your create a filter for those?
Right now I have this. It's adding Direct electronic to our filter for books:

Direct electronic AND (Books OR Books (Manuscripts) ) AND NOT ( Microfilm OR Microfiche OR Microopaque OR Large print OR Braille OR Online OR Regular print reproduction OR Electronic )

item_form=q AND (item_type=a OR item_type=t) AND NOT (item_form=a OR item_form=b OR item_form=c OR item_form=d OR item-form=f OR item_form=o OR item_form=r OR item_form=s)

I thought just:
item_type=a AND item_form=q
should work but it didn't for me.

I want to use:

item_type=a AND 347$3=audio-enabled book

If I can figure out how to use the 3xx fields than I could have a filter for MP3 audiobooks

item_form=i AND 347$b=MP3

I need help creating the record attribute. I see that there are record attributes for the 336 field (rda content type) but content type is $2 rdacontent. The 347 field does not have an rda definition.

Thanks for any help.
Janet

Changed in evergreen:
assignee: Rogan Hamby (rogan-hamby) → nobody
Terran McCanna (tmccanna) wrote :

Adding needsdiscussion tag at request of catalogers working group - more input requested on the best approach, and if Rogan's submitted patch meets everyone's needs.

tags: added: needsdiscussion
Janet Schrader (jschrader) wrote :

I'm not sure ourm network needs it as CWMARS already has a preloaded audio filter, see #4. Isn't this the same? That said I"d say to approve have the CWG discuss new filters (new wishlist bugs?).

Id like to see additional filters as more and more new media keeps coming. In the "old" days all videos were "Videorecordings" until we differentiated between DVD and Blu-ray, a change greatly appreciated by patrons. Now we need to differentiate between CD Audiobooks and MP3 Audiobooks. Blu-ray and 4K Ultra HD.

Janet

Elaine Hardy (ehardy) wrote :

This may be a good place to begin a CWG discussion on how to integrate the MARC fields designed for RDA and that drill down specifically and granularly in an items attributes that might be important to user discovery -- anything from fields that define format to those that provide contributor characteristics.

Janet Schrader (jschrader) wrote :

Thank you, Elaine. That's what I've been trying to do and I doubt that I'm the only one.

Janet Schrader (jschrader) wrote :

I tested this bug on Terran's test server. I imported several records for Playaways and all displayed the Pre-loaded audio icon. TCNs 251, 252, 253, 254.
I had to edit one because the Form was coded a 's' and not 'q'.

Janet

Jennifer Weston (jweston) wrote :

Testing is successful for this specific scenario -- create new format for Preloaded Audio and use the item type of 'i' and item form of 'q'. Some libraries already have this but it would be nice to make it available to all without requiring individual customization.

Created new bug #1892038 to continue conversation about creating record attributes for RDA fields and beyond.

I have tested this code and consent to signing off on it with my name, jweston <email address hidden>

tags: added: signedoff
Changed in evergreen:
status: New → Confirmed
Galen Charlton (gmc) wrote :

Pushed to master for inclusion in 3.6. Thanks, Rogan, Jennifer, and CWG!

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 3.6-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers