Add Evergreen support for Debian 10 Buster

Bug #1835458 reported by Ben Shum
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned
OpenSRF
Wishlist
Unassigned

Bug Description

Evergreen master
OpenSRF master

Testing with Debian 10 Buster RC2 (plus some updates). Debian 10 is expected to arrive around July 6, 2019 in a few days. Adding some initial support for both OpenSRF and Evergreen.

Revision history for this message
Ben Shum (bshum) wrote :

This is the start of working branch for OpenSRF: user/bshum/debian10

https://git.evergreen-ils.org/?p=working/OpenSRF.git;a=shortlog;h=refs/heads/user/bshum/debian10

One untested area is that we're changing the core dependency from libgcrypt11-dev to libgcrypt20-dev (because this is the only one that exists for Debian 10 Buster). Need to test that past distros will be OK with this change. I see the packages do exist, but requires further testing before we pass this through.

Revision history for this message
Ben Shum (bshum) wrote :

Also started working branch for Evergreen: user/bshum/debian10

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/debian10

The issue with Evergreen install is that the newest version of libssl (1.1.1+) for Debian 10 does not work properly when trying to build the web client and phantomjs fails to run with errors like:

libssl_conf.so: cannot open shared object file: No such file or directory

The workaround for this is to use a command like "export OPENSSL_CONF=/etc/ssl/" to set the OPENSSL_CONF variable for the user prior to running the other commands. We need to check further upstream activity regarding the changes in libssl version to see if there will be other solutions or if we need to document this step somewhere in our README process in the meantime.

Changed in evergreen:
status: New → Confirmed
Changed in opensrf:
status: New → Confirmed
Changed in evergreen:
milestone: none → 3.next
milestone: 3.next → 3.4-beta1
Changed in opensrf:
milestone: none → 3.1.2
Revision history for this message
Jason Stephenson (jstephenson) wrote :

I have done a little more than kick the tires with these two branches over the weekend. I ran all the tests and used them to fix a bug and do a little hacking.

I have pushed sign off branches to the working repo, because Ben Shum mentioned possibly updating the README for OpenSRF to indicate where the mod_legacy_auth directive should be add to ejabberd.yml.

My signoffs:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1835458-debian10-signoff

https://git.evergreen-ils.org/?p=working/OpenSRF.git;a=shortlog;h=refs/heads/user/dyrcona/lp1835458-debian10-signoff

I targeted this at the next releases. I'm not entirely sure that we want to add support for a new distro in an OpenSRF bug fix release, but IIRC, we have removed them in the past, so there's a sort of precedent for that.

tags: added: pullrequest signedoff
Ben Shum (bshum)
Changed in opensrf:
milestone: 3.1.2 → 3.2-beta
Revision history for this message
Jason Stephenson (jstephenson) wrote :

I rebased my signoff branches on master this morning and force pushed. They rebased cleanly.

Revision history for this message
Ben Shum (bshum) wrote :

Grabbed Jason's signed off branches and pushed to OpenSRF and Evergreen master.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in opensrf:
status: Confirmed → Fix Committed
Galen Charlton (gmc)
Changed in evergreen:
importance: Undecided → Medium
Changed in opensrf:
importance: Undecided → Medium
Changed in evergreen:
importance: Medium → Wishlist
Changed in opensrf:
importance: Medium → Wishlist
Changed in evergreen:
status: Fix Committed → Fix Released
Changed in opensrf:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers