bump up ng-bootstrap version for Angular staff interface

Bug #1831907 reported by Galen Charlton on 2019-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

The Angular staff interface current requires ng-bootstrap ^3.3.0. It's probably time to bump it up.

The original motivation was getting more keyboard navigation for ngbPopover, which was added in ng-bootstrap 4.1.0, but testing of the patch for bug 1831780 turned up a z-index issue with ng-bootstrap dateselect whose fix is available in 4.1.2.

Galen Charlton (gmc) wrote :

Very preliminary testing of ng-bootstrap 4.2.1 did not cause a blowup, so I'll pursue this further.

It does look like this commit (https://github.com/ng-bootstrap/ng-bootstrap/commit/a25d5d2) bears the most testing.

Changed in evergreen:
milestone: none → 3.4-beta1
importance: Undecided → Wishlist
assignee: nobody → Galen Charlton (gmc)
Jane Sandberg (sandbej) on 2019-06-09
tags: added: angular
Jane Sandberg (sandbej) on 2019-06-13
Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick) wrote :

Just adding a note that I updated my local copy of ng-bootstrap to 4.1.2 and did some tests. I was not able to find any problems.

Galen Charlton (gmc) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Bill Erickson (berick) on 2019-07-30
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Thanks, Galen. Poked around some more and didn't find any issues. Merged to master.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers