Add access to juvenile flag in checkout print template

Bug #1830387 reported by Terran McCanna
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Wishlist
Unassigned

Bug Description

As discussed on the OPEN-ILS-GENERAL list, having access to the juvenile flag in the checkout print template would be useful in order to show/hide content based on patron age.

Examples: Upcoming events, raffle info, etc.

Revision history for this message
John Amundson (jamundson) wrote :

I want to note that the field {{patron.juvenile}} will produce a response in the template preview but not when a receipt prints.

In theory, the following should achieve the desired result:

<div ng-if="patron.juvenile=='f'">Raffle Details here!!</div>

If fixing access to this field in the checkout receipt template, the Items Out and Renew templates should also be fixed.

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Terran McCanna (tmccanna) wrote :

Added access to juvenile flag to checkout and items out templates - did not add to renew template because it is not set up the same way to include patron info. If that is needed, I think it should be a separate ticket.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mccanna/lp1830387_print_templates_juvenile_flag

tags: added: pullrequest
Revision history for this message
Jennifer Weston (jweston) wrote :

Tested and works as expected. Messages can be now be added to display or not depending upon juvenile flag. Great additional functionality, Terran!

https://terran-testbox.gapines.org/eg/staff

I have tested this code and consent to signing off on it with my name, Jennifer Weston, and my email address, <email address hidden>

tags: added: signedoff
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed for inclusion in 3.9, along with follow-up patches to normalize whitespace and add a release notes entry. Thanks, Terran and Jennifer!

Changed in evergreen:
milestone: none → 3.9-beta
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers