Angular client needs more keyboard shortcuts to be added

Bug #1829567 reported by Jane Sandberg
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.3
Medium
Unassigned

Bug Description

Currently, many of the function keys are not mapped to the relevant actions (for example, F1 does not open the Check Out interface).

F5 is mapped to Item Status, and it looks like a good example for how to add this functionality: https://github.com/evergreen-library-system/Evergreen/blob/master/Open-ILS/src/eg2/src/app/staff/nav.component.html#L101

Related bug: https://bugs.launchpad.net/evergreen/+bug/1622358

This is in master

Revision history for this message
Kate Coleman (katecoleman) wrote :

Cannot confirm as in my testing using 3.1.10, I have the current shortcuts:

F1 - Checkout
F2 - Checkin
F3 - Advanced Search
F4 - Patron Search
F5 - Item Status
F6 - In-House Use
F8 - Retrieve Last Patron

Revision history for this message
Anna Goben (agoben) wrote :

See also: https://bugs.launchpad.net/evergreen/+bug/1437106

The shortcut/hotkey failure still only occurs in the Dojo/OPAC interfaces as of 3.2.

Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks for taking a look, Kate and Anna. To be clear, my bug is about the new Angular screens, such as:
1) Acquisitions Administration
2) System Administration
3) MARC Batch Import/Export
4) The Experimental Staff Catalog

Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: New → Confirmed
Revision history for this message
Bill Erickson (berick) wrote :

Branch:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1829567-ang-accesskey-navbar-updates

From the 2 commits:

===

Adds keyboard shortcuts to the Angular navigation bar for the following actions using the same key assignments as AngJS.

Patron Search
Item Status
OPAC
Check Out
Check In
Capture Holds
Renew items
Register Patron
Retrieve Last Patron
Retrieve Recent Patrons
Record In-House Use
Reprint Last Receipt
Retrieve Bib Record by TCN
Retrieve Last Bib Record

---

1. Adds support for shift+ shortcuts.
2. Remove duplicate key assignments made within the same context. This is especially useful in the navigation bar since some commands repeat from different menus.
3. Indicate in the key assignments help page when an assignment has be superseded by another assignment.
4. Open the help page in large-dialog mode for more room.

Changed in evergreen:
milestone: none → 3.4-beta1
tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Bill Erickson (berick) wrote :

Targeting 3.4-beta, however I could see these getting back-ported to 3.2/3.3 depending on how cleanly they merge.

Galen Charlton (gmc)
Changed in evergreen:
importance: Undecided → Medium
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Looks good. Signoff pushed to working/user/gmcharlt/lp1829567_signoff.

I'll add 3.2 and 3.3 targets. The backport to 3.3 is easy; the backport to 3.2 looks a bit less easy but not awful.

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
milestone: 3.4-beta1 → 3.3.3
tags: added: signedoff
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_3, rel_3_2, and rel_3_1. Thanks, Rogan and Jane!

Changed in evergreen:
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Revision history for this message
Galen Charlton (gmc) wrote :

Whoops, comment #7 was meant for a different bug. Please disregard.

Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Here's a branch compatible with 3.2:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1829567-ang-accesskey-navbar-updates-3.2

In addition to the changes for this bug, it includes fixes for 2 menu items that were the source of the merge conflicts: "Home" goes to AngJS home and "Catalog" goes to embedded catalog instead of the Angular catalog.

I was not comfortable merging to 3.2, though, since I don't have system handy to test on.

Looking at merging to 3.3+ now...

Revision history for this message
Bill Erickson (berick) wrote :

Patches for 3.3 and master merged.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
no longer affects: evergreen/3.4
Changed in evergreen:
milestone: 3.3.3 → 3.4-beta1
Galen Charlton (gmc)
no longer affects: evergreen/3.2
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers