OPAC View Holds change or set different default pickup library

Bug #1825201 reported by Lindsay Stratton on 2019-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Currently (at least in 3.1.13), the OPAC > View Holds list display defaults to show only holds on the given title for pickup at the workstation library. To see consortia wide holds, or other libraries, it requires extra steps/clicks. In our consortia, almost all staff change the list to see ALL holds on the title for ALL pickup libraries.

Would it be possible to add that functionality to the View Holds list?

Andrea Neiman (aneiman) on 2019-04-17
tags: added: holds usability
removed: viewholds
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Michele Morgan (mmorgan) wrote :

I would be inclined to mark this bug as a duplicate of bug 1665534 which has a fix released as of 3.1.11, 3.2.5, 3.3.0.

In the xul client, there was a checkbox to filter the display of holds, and a dropdown to choose the pickup location for the filter. Both of these were sticky settings, but by default, holds were filtered to those for pickup at the workstation library. Un-checking the checkbox would unfilter the list, showing all holds. Once unchecked, the choice would be a sticky workstation setting, always showing the unfiltered list of holds.

In the web client, there is no checkbox, just the dropdown to choose pickup library, which by default, is the workstation library. Setting the dropdown to the consortium level will show all holds, and the fix for bug 166554 will make that choice a sticky workstation setting so that the unfiltered list will always be shown.

Unless others disagree, I'll mark this as a duplicate of 1665534.

Revision history for this message
Lindsay Stratton (lstratton) wrote :

1665534 does seem to accomplish the same thing, good to know there is a fix.

Revision history for this message
Michele Morgan (mmorgan) wrote :

Thanks Lindsay, marking this a duplicate of 1665534.

Revision history for this message
Andrea Neiman (aneiman) wrote :

Thanks for the catch, Michele -- I tested very quickly on 3.2.2 and didn't do my homework :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers