Opening PO in new tab causes PO not to load fully

Bug #1813290 reported by Tiffany Little on 2019-01-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

Found on 3.2.2.

If you search for a purchase order and load the purchase order, everything will load correctly. However, if you pop out the PO into its own tab by clicking the "Open in New Window" button the purchase order will only partially load. Line items are not fully populated. Letting it sit for a while does not help. You also get this console error:

Uncaught ReferenceError: IAMBROWSER is not defined
at AcqLiTable.addLineitem (li_table.js:790)
at OpenSRF.Request.onresponse (view_po.js:496)
at Function.OpenSRF.Stack.handle_message (eval at dojo.eval (dojo.js:16), :747:28)
at Function.OpenSRF.Stack.push (eval at dojo.eval (dojo.js:16), :692:23)
at OpenSRF.XHRequest.core_handler (eval at dojo.eval (dojo.js:16), :106:19)
at OpenSRF.XHRequest.send (eval at dojo.eval (dojo.js:16), :92:14)
at OpenSRF.ClientSession.OpenSRF.Session.send_xhr (eval at dojo.eval (dojo.js:16), :308:43)
at OpenSRF.ClientSession.OpenSRF.Session.send (eval at dojo.eval (dojo.js:16), :298:25)
at OpenSRF.Request.send (eval at dojo.eval (dojo.js:16), :611:18)
at Object.fieldmapper._request (eval at dojo.eval (dojo.js:16), :200:27)

I went back and confirmed that this is working properly on our previous 3.0.2 system.

John Amundson (jamundson) wrote :

I am also seeing this behavior with Selection Lists, as well in 3.2.2. Our 3.0.13 system works fine.

Changed in evergreen:
status: New → Confirmed
Changed in evergreen:
importance: Undecided → High
assignee: nobody → Jason Stephenson (jstephenson)
milestone: none → 3.3-beta1
Jason Stephenson (jstephenson) wrote :

John, here at CW MARS, identified the file with the problem and we implemented a fix on our 3.2.3 training system. The fix works, so we've pushed it to a working branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1813290-window-IAMBROWSER-fix

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
tags: added: pullrequest
Tiffany Little (tslittle) wrote :

This works for us. Thanks Jason and John!

I have tested this code and consent to signing off on it with my name, Tiffany Little, and my email address, <email address hidden>.

tags: added: signedoff
Galen Charlton (gmc) on 2019-02-18
Changed in evergreen:
milestone: 3.3-beta1 → 3.2.4
no longer affects: evergreen/3.2
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Pushed to master and rel_3_2. Thanks, John, Jason, and Tiffany!

tags: added: regression
Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers