Notify by Email column on Hold Shelf not populating

Bug #1813088 reported by Terran McCanna on 2019-01-23
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.3
Undecided
Unassigned
3.4
Undecided
Unassigned

Bug Description

In 3.2.2 and 3.0.2: The 'Notify by Email?' (Yes/No) column can be displayed but does not populate on the Hold Shelf screen.

Revision history for this message
John Amundson (jamundson) wrote :

This column is displaying Yes/No on our production server, (3.0.12), but is not populating on our training server, (3.2.2).

Changed in evergreen:
status: New → Confirmed
tags: added: holds
Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

This column displays but doesn't populate values in the Hold Shelf or View Holds (in the record) in 3.3.4

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Values (Yes/No) populate on our 3.1.7 test server for both Hold Shelf and View Holds.

Andrea Neiman (aneiman) on 2019-10-15
tags: added: regression
Revision history for this message
Jason Stephenson (jstephenson) wrote :

This looks to be a more general bug than just this one field. None of the Boolean fields populate values for me on a 3.2 test system. I suspect this is related to the hold fetch speed up code introduced in bug 1712854. The code for that appears in Evergreen 3.2+, but not 3.0 nor 3.1.

I'm looking into it to see if I can come up with a fix. I think it has something to do with the eg-grid setup in t_holds_shelf_list.tt2.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Revision history for this message
Jason Stephenson (jstephenson) wrote :

It turns out that the problem was an integer versus string value in egGridFilterValue. The branch below alters the check for Boolean columns to force a comparison on string types. Thanks to Mike Rylander for pointing out the type mismatch in IRC!

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1813088-egvf-bool-coercion

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
milestone: none → 3.5.0
tags: added: pullrequest
Revision history for this message
John Amundson (jamundson) wrote :

Thanks for your work on this patch, Jason.

I have tested this internally, and the column is displaying perfectly. Other Boolean columns are also displaying correctly, such as "Copy Deleted".

Since Jason and I are part of the same organization, I won't add a formal sign off, but this can be considered an informal one from me.

Revision history for this message
Chris Sharp (chrissharp123) wrote :

Works for me too. Pushed to 3.3, 3.4, 3.5, and master. Thanks, John and Jason!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers