reporter.simple_record mistakenly allows multiple/bogus values for pubdate

Bug #1812698 reported by Chris Sharp on 2019-01-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.1
High
Unassigned
3.2
High
Unassigned

Bug Description

Found after PINES upgraded to 3.2.2. Publishers and publication dates were inconsistently showing in copy buckets and other views. Found a copypasta error dating from 2014 causing the trouble. Branch on the way.

Evergreen 2.7 through 3.2.2
OpenSRF 3.0.1
Ubuntu 16.04
PostgreSQL 9.5

Chris Sharp (chrissharp123) wrote :

Here it is:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/lp1812698_fix_reporter_simple_record_pubdate

Marking high importance since this breaks bib display in multiple interfaces, including reports.

tags: added: pullrequest
Changed in evergreen:
importance: Undecided → High
Ben Shum (bshum) wrote :

Confirmed issue and picked fix for master and backported to 3.2 and 3.1.

Changed in evergreen:
milestone: none → 3.3-beta1
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers