The angular fmeditor does not associate its label and input tags

Bug #1807523 reported by Jane Sandberg on 2018-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

Associating labels and inputs is important for accessibility. Branch forthcoming.

Revision history for this message
Jane Sandberg (sandbej) wrote :

I created a branch to fix this called user/sandbergja/lp1807523_angular_fmeditor_labels_inputs

Here's a link: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1807523_angular_fmeditor_labels_inputs

tags: added: pullrequest
Revision history for this message
Bill Erickson (berick) wrote :

Thanks for the bug/patch, Jane! I eyeballed the patch and it will certainly get the job done. However, I'm hesitant to apply predictable DOM ID's to components where multiple instances could be active in a single page, since the possibility exists for ID's to get clobbered. (Not terribly likely in this case, but certainly possible).

Perhaps we could teach FmEditorComponent to add a bit of randomness to its field IDs. E.g.

TS
ngOnInit() {
  ...
  this.domId = 'fm-editor-' + Math.random();
}

HTML
<input id='{{this.domId}}-{{field-name}}' ... />

Revision history for this message
Jane Sandberg (sandbej) wrote :

Good idea, Bill. I added a follow up commit to that branch to add a bit of randomness to the IDs that are generated.

Bill Erickson (berick) on 2018-12-17
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: New → Confirmed
milestone: none → 3.2.3
Revision history for this message
Bill Erickson (berick) wrote :

Looks great, thanks Jane! Merged to master and 3.2.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
milestone: 3.2.3 → 3.3-beta1
status: Fix Committed → Fix Released
Changed in evergreen:
status: Fix Released → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers