Add Billing History grid persist-key to server-side db settings

Bug #1806709 reported by Remington Steed on 2018-12-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

In bug 1739606, the persist-key was added to the Billing History grid. But as of bug 1750894, "New browser client settings/preferences that should persist across browser sessions require a DB upgrade script to add the needed rows to config.worksation_setting_type" (see Bill's email https://markmail.org/message/szdxnu6lolvhkgjd).

This bug is for adding the required upgrade script (add the persist key "circ.patron.billhistory_xacts" to config.workstation_setting_type). Thanks to Michele Morgan for the tip.

Remington Steed (rjs7) wrote :

You can see examples of these db setting entries in this commit (search for "eg.grid"):

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=33f531f88e1136b804ca393d0d40b3ed8f37ac7b#patch7

Here's one example:

(
  'eg.grid.cat.bucket.record.view', 'gui', 'object',
  oils_i18n_gettext(
    'eg.grid.cat.bucket.record.view',
    'Grid Config: cat.bucket.record.view',
    'cwst', 'label'
  )
)

Changed in evergreen:
milestone: 3.2.3 → 3.3-beta1
assignee: nobody → Jason Stephenson (jstephenson)
Jason Stephenson (jstephenson) wrote :

I have pushed two branches to resolve the hastiness of the commit of the fix for bug 1739606 to the working repository.

The first branch, user/dyrcona/lp1806709-billing-history-grid-persist-key (http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1806709-billing-history-grid-persist-key), adds 'eg.grid.' to the persist key name and adds the appropriate entry to config.workstation_setting_type. This branch should be applied to master and to rel_3_2.

The second branch, user/dyrcona/lp1806709-fix-persist-key-rel_3_1 (http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1806709-fix-persist-key-rel_3_1),is only for rel_3_1. It adds 'eg.grid.' in front of the persist key name.

The rel_3_1 branch works great. I'm not sure if anything is wrong with the branch for master. When I tested it just now, the settings are still created in local storage. I don't seen anything added to actor.workstation_setting when saving the column configuration. Perhaps I misunderstand what is supposed to happen?

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
Jason Stephenson (jstephenson) wrote :

I have added the pullrequest tag in the hope that someone else can look at this and see what I may have missed.

tags: added: pullrequest
Jason Stephenson (jstephenson) wrote :

Remove the pullrequest tag to try a fix suggested by Michele Morgan.

tags: removed: pullrequest
no longer affects: evergreen/3.1
Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Jason Stephenson (jstephenson) wrote :

OK! It is working for me after removing "eg.grid." from the persist key in the template as recommended by Michele Morgan. This means that no changes are required for Evergreen 3.1, so disregard the branches in comment #2.

The new branch for master/rel_3_2 is user/dyrcona/lp1806709-billing-history-grid-persist-key-rebase:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1806709-billing-history-grid-persist-key-rebase

I have once again added the pullrequest tag since the change works for me, and I get the columns settings persisted in the database.

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
tags: added: publlrequest
Remington Steed (rjs7) wrote :

Thanks Jason for making quick work of this! I still think it needs to go into 3.1, though, since the incomplete change went in there also. Unless you had a reason against that?

tags: added: pullrequest
removed: publlrequest
Jason Stephenson (jstephenson) wrote :

Remington,

Evergreen 3.1 doesn't store settings on the server. The schema lacks the config.workstation_setting_type table, so the database updates do not apply to 3.1.

Please, correct me if I'm wrong, but I don't see the table after loading a 3.1 schema into a database.

Jason

Remington Steed (rjs7) wrote :

Sorry, I was thinking of something else. You're right, the server-side settings are new in 3.2.

Michele Morgan (mmorgan) wrote :

Tested this as follows: Applied the patch, logged into the client and made changes the column settings on the Bill History Transactions screen. Saved the columns and confirmed that a row was added to actor.workstation_setting for the saved columns.

Logged into the client again and confirmed that the saved columns applied.

My signoff branch is at:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=61521cfb89d734740b3f93c750a538adc253c7e0

tags: added: signedoff
Galen Charlton (gmc) on 2019-02-18
Changed in evergreen:
milestone: 3.3-beta1 → 3.2.4
no longer affects: evergreen/3.2
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Pushed to master and rel_3_2. Thanks, Jason and Michele!

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers