Password Reset results in Internal Server Error

Bug #1804038 reported by Jason Boyer on 2018-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.1
High
Unassigned
3.2
Undecided
Unassigned

Bug Description

Eg 3.2

The changes to Actor.pm in bug 1552778 appears to have broken the 2 uses of clense_ISO8601 (used for password reset) that are in that module. Specifying the full module path (OpenSRF::Utils::clense_ISO8601) should correct it.

Jason Boyer (jboyer) on 2018-11-19
Changed in evergreen:
importance: Undecided → High
Kathy Lussier (klussier) on 2018-11-19
Changed in evergreen:
status: New → Confirmed
Jason Boyer (jboyer) wrote :

This branch fixes all 3 undecorated calls to clense_ISO8601 that I found in a cursory search. http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1772062_clense_iso8601 working/user/jboyer/lp1772062_clense_iso8601

To test:
enable password resets
try to perform one, get an Internal Server Error page.
Apply patch
try to perform a password reset, arrive at "it's on its way!" page.

tags: added: pullrequest
Jason Boyer (jboyer) wrote :

Quick note to testers/committers, that is the correct branch to address this bug; I just mis-named it because I had too many LP tabs open apparently.

Dan Wells (dbw2) wrote :

After some chatting in IRC, a new potential branch is here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbwells/lp1804038_fix_old_datetime_function_calls

working/user/dbwells/lp1804038_fix_old_datetime_function_calls

Instead of forcing these through the now defunct OpenSRF versions, let's have them use the new and shiny OpenILS versions.

Jason Boyer (jboyer) wrote :

And I prefer doing things the right way, so after testing Dans' branch everything looks good. Signoff lives here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1804038_iso8601_signoff / working/user/jboyer/lp1804038_iso8601_signoff

Dan Wells (dbw2) on 2018-11-20
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Jason Boyer (jboyer) on 2018-11-20
tags: added: signedoff
Dan Wells (dbw2) wrote :

Pushed to master and rel_3_2. Thanks, Jason!

Also, targeting to 3.1 as another potential tack-on to the WIP for that version.

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 3.3-beta1
Changed in evergreen:
assignee: Dan Wells (dbw2) → nobody
status: Fix Committed → Fix Released
Dan Wells (dbw2) on 2019-03-06
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

Dependent bug #1552778 has now been merged to 3.1, so merging this as well.

Changed in evergreen:
assignee: Dan Wells (dbw2) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers