Due date box in check out has display issues at wider resolutions

Bug #1803406 reported by Andrea Neiman on 2018-11-14
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.2
Medium
Unassigned
3.3
Medium
Unassigned

Bug Description

Tested in 3.2.1 in Chrome and Firefox.

The Check Out interface includes a date options picker, a due date display box, a date picker, and (new in 3.2 via bug 1552778) a time picker.

At resolutions wider than ~ 1000px, the due date display box cuts off a portion of the date. At narrower resolutions, the due date display drops to the line below the date options picker and therefore displays normally.

See screenshot.

I am not seeing this in a 3.1.5 test system (which doesn't have the time picker).

Andrea Neiman (aneiman) wrote :
Changed in evergreen:
status: New → Confirmed
Elizabeth Davis (elidavis) wrote :

We are also experiencing this in 3.1 on our production server and 3.3 on our test server.

Carrie Cleary (ccleary.pails) wrote :

I've looked at this on our test servers running 3.3.

The calendar picker works after you click on the Date Options to turn it green.

As it is set on the resource sharing test server in our consortia now, staff see 2 digit Month — 2 digit day of month; only Year is missing from view.

Dan Briem (dbriem) wrote :

We see this on 3.2 - this patch adjusts the bootstrap .col classes so the due date has more space to display. https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbriem/lp1803406_specific_due_date_obscured

tags: added: pullrequest
Eva Cerninakova (ece) wrote :

We have found the problem in Evergreen 3.3.2 and in the Evergreen 3.3 demo.g?
However, we see only the year (not the day and the month) - could the date format differ due to some setting?

Katherine Dannehl (kadannehl) wrote :

We have the same problem in Evergreen 3.3.3.

We can only see the year and a little bit of the month in the date picker.

Eva Cerninakova (ece) wrote :

Katherine, the following does not solve the bug, however, it might help a little:

In Evergreen 3.3.2 we were able to change the date format, so that the day and month were shown first, not the year (having information about due year was really useless during checkout). The date format was possible to set (probably unintentionally) in the Administration -> Local Li Administration -> Library Settings editor -> Deprecated: Format Dates with this pattern.

Michele Morgan (mmorgan) on 2019-09-11
Changed in evergreen:
milestone: none → 3.4-beta2
Galen Charlton (gmc) on 2019-10-02
Changed in evergreen:
milestone: 3.4-beta2 → 3.4.1
Changed in evergreen:
milestone: 3.4.1 → 3.4.2
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_4, rel_3_3, and rel_3_2. Thanks, Dan and Terran!

Changed in evergreen:
importance: Undecided → Medium
assignee: nobody → Galen Charlton (gmc)
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers