The icons on the web staff client splash page should also link to the appropriate screens

Bug #1802662 reported by Jane Sandberg on 2018-11-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Currently, when you click on the icons on the main splash page (for example the image of the person next to some binoculars that indicates "Search for Patron by Name"), nothing happens. I think that these icons should be added to the <a> tags so that user can click on them.

Accessibility-related info here (tl;dr we should use a single <a> tag for both the image and the link, rather than give each one a separate <a> tag): https://www.w3.org/TR/WCAG20-TECHS/H2.html

This affects both the angularjs and angular 7 web client splash pages.

Changed in evergreen:
status: New → Confirmed
Sam Link (slink-g) on 2018-12-13
Changed in evergreen:
assignee: nobody → Sam Link (slink-g)
Sam Link (slink-g) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Sam Link (slink-g) → nobody
Jane Sandberg (sandbej) wrote :

Thanks for this, Sam. Looks good to me!

I pushed a rebased and signed-off branch called user/sandbergja/lp1802662_linked_icons_on_splash_page_signoff

tags: added: signedoff
Bill Erickson (berick) wrote :

Does what it says. Thanks Sam, Thanks Jane. Merged to 3.2 and above.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
milestone: none → 3.2.5
assignee: Bill Erickson (berick) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers