Images on main splash screen should have alt attributes

Bug #1802594 reported by Jane Sandberg on 2018-11-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned

Bug Description

The splash page of both the AngJS and Ang7 web client both have several images (the Evergreen logo, as well as icons for various Evergreen tools). None of these images have the required alt tag.

Since the icons don't add any particular information, I propose that they have alt="" and role="presentation".

Since the Evergreen logo does provide additional information for sighted users, I propose that it have alt="Evergreen".

Sam Link (slink-g) wrote :
tags: added: pullrequest
Changed in evergreen:
status: New → Confirmed
Jane Sandberg (sandbej) wrote :

Thanks for doing this, Sam! It looks good to me. Two notes from eyeballing your branch:

1) It doesn't look like it modifies the new (as of 3.2) Angular client's splash page. That splash page is at Open-ILS/src/eg2/src/app/staff/splash.component.html, and would need the same alt and role attributes.

2) It looks like there is an extra commit in your branch (called initial commit) that doesn't have to do with the splash screens.

Sam Link (slink-g) wrote :

I'll fix 1) and resubmit; 2) is just a habit when I make a new branch to make sure everything is current.

Jason Stephenson (jstephenson) wrote :

Sam, 2 is a bad habit to get into. It can lead to confusion and busted code.

Please, checkout a fresh branch based on master, cherry-pick only the relevant changes for this bug into that branch, and then push that branch to the working repository.

Thanks,
Jason

Sam Link (slink-g) wrote :

Thanks for the help and lesson in best practices! New, clean fix is pushed here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/slink/LP1802594_Splash_Page_Alt_Text

Thanks again,
Sam

Jane Sandberg (sandbej) wrote :

Works well for me, Sam. Thanks for the contribution!

Signed-off branch here: user/sandbergja/LP1802594_Splash_Page_Alt_Text_signoff

tags: added: signedoff
Galen Charlton (gmc) on 2019-02-18
Changed in evergreen:
importance: Undecided → Low
milestone: none → 3.2.4
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Pushed to master and rel_3_2, along with a follow-up to prevent a minor regression on the "Copy" => "Item" great relabeling. Thanks, Sam and Jane!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers