Transition to Angular version 7.

Bug #1801984 reported by Bill Erickson on 2018-11-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.2
High
Unassigned

Bug Description

Angular version 7 is now available:

https://blog.angular.io/version-7-of-angular-cli-prompts-virtual-scroll-drag-and-drop-and-more-c594e22e7b8c

According to the release post and https://update.angular.io/ it should be a fairly minor update.

Bill Erickson (berick) wrote :

Changes pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1801984-angular-7

Most of the migration was automated via tools provided by Angular. After applying the updated versions in package.json, I removed the node_modules directory, did a new 'npm install', did a dev and prod build, and tested the UI. All looks good from here.

tags: added: pullrequest webstaffclient
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Bill Erickson (berick) wrote :

Rebasing to master to make sure no additional changes are required...
Going to mark this high priority since all other Ang6 dev will be affected by it.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Branch rebased to current master. I also updated via npm and we are now on Angular 7.2 (w/ updated dependencies).

I also explicitly added "@nguniversal/express-engine" to resolve the intermittent ngx-cookie compile errors.

To test:
cd Open-ILS/src/eg2
rm -f node_modules
npm install
ng build --prod

Changed in evergreen:
importance: Undecided → High
assignee: Bill Erickson (berick) → nobody
Bill Erickson (berick) wrote :

I have confirmed the code also merges and works fine in rel_3_2. I added 3.2 as a target, since the Angular 7 update fixes some compile errors that have recently popped up:

ERROR in ../ngx-cookie/ngx-cookie.ts(10,23): Error during template compile of 'CookieBackendService'
  Could not resolve @nguniversal/express-engine/tokens relative to /home/berick/code/Evergreen/Open-ILS/src/eg2/node_modules/ngx-cookie/ngx-cookie.d.ts..
node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.

Jason Boyer (jboyer) wrote :

I've also tested this code against rel_3_2, signoff here: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1801984-ang7-signoff / working/user/jboyer/lp1801984-ang7-signoff

Jason Stephenson (jstephenson) wrote :

All of the tests pass for me, and the new Angular UIs still work and look good.

I added my sign off and pushed to master and rel_3_2 for the future!

Thanks, Bill & Jason!

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers