Recalls can extend loan period

Bug #1801191 reported by Jeff Davis on 2018-11-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

EG 3.1+

When a checked-out title is recalled, the due date of the current checkout is reset to a new return date based on library settings (either checkout time + recall threshold or now + recall interval, whichever is later). The expectation is that the loan period will be truncated, but EG will use the new return date even if it is later than the current due date. Thus, for example, if the return date is 5 days in the future but the item was originally due 3 days from now, the due date will actually be extended to 5 days from now.

EG should probably compare the return date to the current due date, and set the due date to whichever date is soonest.

I believe both the old and the new hold targeter are affected by this. I haven't confirmed it yet in a test environment, but I've had reports of this behavior in the wild.

tags: added: holds recalls
Jeff Davis (jdavis-sitka) wrote :

Working branch user/jeffdavis/lp1801191-recall-due-date has an untested fix. I'll add a pullrequest tag once I've had a chance to actually try it out.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeffdavis/lp1801191-recall-due-date

Jeff Davis (jdavis-sitka) wrote :

This turns out to be painful to test because of bug 1804716, which prevents recalls from working properly.

Jeff Davis (jdavis-sitka) wrote :

I've force-pushed an update to the branch. The revised fix works for me in testing.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.3-beta1
Dan Wells (dbw2) on 2019-02-06
Changed in evergreen:
importance: Undecided → Wishlist
no longer affects: evergreen/3.2
no longer affects: evergreen/3.1
Remington Steed (rjs7) wrote :

I have reviewed and signed off on Jeff's change. However, I am not familiar enough with recalls to properly test it. I can say, though, that his code looks correct, it compiles, and the new hold-targeter runs without errors.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/lp1801191-recall-due-date

Dan Wells (dbw2) wrote :

I was able to test this on the install Remington set up, and ran into an issue with 'cleanse_ISO8601' vs 'clean_ISO8601'. Remington did a little clean up to the branch, and I have tested it successfully and pushed in both commits to master.

Thanks, Jeff and Remington!

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers