Web Client: Item Status does not Display Precat Title, Author, etc

Bug #1801137 reported by John Amundson
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.3
High
Unassigned

Bug Description

Evergreen 3.0.13 and 3.2.1

In the web client, precat items do not display correctly in Item Status. Namely, the following fields are blank:
Title
Author
ISBN

For precat records, this information comes from the "Dummy" fields in the copy record.

Currently in the web client Checkout and Items Out both display these fields in the basic Title, Author, etc columns. These screens also have access to the "Dummy" fields themselves, so there are multiple ways of displaying precat information.

Item Status does not have access to the "Dummy" fields so they cannot even be displayed that way.

My preference would be to have the dummy title, author, and ISBN simply display under the Title, Author, and ISBN fields in Item Status similarly to the way they do currently in Web Client's Checkout and Items Out as well as the XUL client's Item Status screen, (see attached).

Revision history for this message
John Amundson (jamundson) wrote :
Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Confirmed that this is an issue in 3.1.7. My preference is also to have the same behaviour as in the web client check out and items out and xul item status.

Changed in evergreen:
status: New → Confirmed
Michele Morgan (mmorgan)
tags: added: webstaffcolumns
Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Confirming this is still an issue in 3.3

Changed in evergreen:
milestone: none → 3.4.1
Changed in evergreen:
milestone: 3.4.1 → 3.4.2
Changed in evergreen:
milestone: 3.4.2 → 3.4.3
Revision history for this message
Lynn Floyd (lfloyd) wrote :

This would be useful, as trying to figure out which item is the precat item in a large list without checking every title in the list.

Changed in evergreen:
importance: Undecided → High
Kyle Huckins (khuckins)
Changed in evergreen:
assignee: nobody → Kyle Huckins (khuckins)
Revision history for this message
Kyle Huckins (khuckins) wrote :
Changed in evergreen:
assignee: Kyle Huckins (khuckins) → nobody
tags: added: pullrequest
Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks for the branch, Kyle. It looks like there is a copy/pasto in the t_list file (all three columns just show the dummy title, instead of dummy author and dummy isbn).

Also, it would be nice to remove the link in the title column for precats. It just links to /eg/staff/cat/catalog/record/-1, which is not much use.

tags: added: needsrepatch
Revision history for this message
Kyle Huckins (khuckins) wrote :

Thanks Jane! I've rebasil'd the copy/pasta, and removed the title column link for precats, as well as making some wording changes("Dummy title" to "Precat title") after some additional feedback, and updated the branch.

tags: removed: needsrepatch
Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Tested on our 3.5beta server and the title, author, and ISBN are displaying in Item Status in the expected places. I love that the pre-cat title isn't a link in Item Status to the -1 catalogue record.

I have tested this code and consent to signing off on it with my name, Jennifer Pringle, and my email address, <email address hidden>

tags: added: signedoff
Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks, Kyle and Jennifer! The rebasil'd pasta was delicious. Pushed to master, rel_3_5, rel_3_4, and rel_3_3.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers