Webstaff: Lines added to checkout grid blank on checkout

Bug #1794176 reported by Dan Wells on 2018-09-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.0
Undecided
Unassigned
3.1
Undecided
Unassigned

Bug Description

When performing a checkout on current webstaff master (circa 3.2-rc), the checkout rows are blank. If you switch interfaces and return, or do another checkout, the data for that row appears normally. This is likely due to additional runs of $scope.gridDataProvider.refresh().

One working fix is to simply add $scope.gridDataProvider.refresh() to the .finally() block of the checkout process in /staff/circ/patron/checkout.js. That said, this seems likely to be a kludge, given that it appears to have worked fine for quite sometime without this additional refresh.

Dan Wells (dbw2) on 2018-09-24
Changed in evergreen:
milestone: none → 3.2-rc
importance: Undecided → High
summary: - Webstaff: Checkout grid shows blank lines on checkout
+ Webstaff: Lines added to checkout grid blank on checkout
Bill Erickson (berick) on 2018-09-24
Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick) on 2018-09-24
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Fix pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1794176-grid-tooltip-more-dynamic

Long story short, the grid tooltip logic captured cell contents into a variable so it could use the same data for both the tooltip and the cell contents, this way it would not have to generate values twice for each cell. It was essentially caching grid values inside an ng-init variable. Doh! Rolled back the optimization.

Included is a change to how the tooltips are generated for HTML-compiled cells. Instead of showing the compiled HTML it shows the text extracted from the HTML, similar with what's displayed in the CVS/Print grid. This was necessary to avoid a $digest loop. The only difference this should make in practice is it's not possible to click on links (etc) embedded in grid tooltips.

tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Dan Wells (dbw2) on 2018-09-24
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

Fix works and looks sane to me. Thanks, Bill! Pushed to master, rel_3_1, and rel_3_0.

P.S. rel_3_0 didn't backport cleanly, so while it seemed a straightforward resolution, more eyeballs on that branch would be appreciated. We wouldn't want to brown-bag the final 3.0 release! :)

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Dan Wells (dbw2) → nobody
Jason Stephenson (jstephenson) wrote :

Dan Wells, et al.

The backport to 3.0 looked good to me when I eyeballed it last night.

I installed it with my upgrade branch for 3.0 this morning on a test vm with production data. I checked out 10 copies to my own account and the view refreshed and displayed each checkout (with a slight delay) after each checkout completed.

So, looks like the 3.0 version is working.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers