Batch Apply for a Volume does not pull the Call Number from the MARC record

Bug #1793196 reported by Garry Collum on 2018-09-18
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

eg 3.0.11 and current master

In the XUL client when the user adds or edits a volume the call number field in the 'batch' apply bar has a dropdown list that is populated with call number(s) that are pulled from the MARC record. This dropdown is not present in the web client.

The top portion of the attached file shows the volume and copy creator from the XUL client displaying the data from tcn 30 of the concerto data. The call number in the dropdown list is pulled from the 050a. The bottom portion is the same data from the web client.

Garry Collum (gcollum) wrote :
Bill Erickson (berick) on 2019-02-05
Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick) on 2019-02-05
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Branch pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1793196-vol-edit-marc-cn

Commit also includes some sanity checks on volcopy editor utility functions to resolve a number of console errors (dereferencing undefined values).

Extra eyes appreciated. Of note, the call to $scope.applyDefaults() now happens after the anon cache data (with record details, etc.) is fetched, so that the value for $scope.record_id is set. Since no code was waiting on $scope.applyDefaults() to complete, calling it later did not appear to be an issue.

Changed in evergreen:
milestone: none → 3.2.4
assignee: Bill Erickson (berick) → nobody
tags: added: pullrequest
Dan Wells (dbw2) on 2019-02-13
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Changed in evergreen:
milestone: 3.2.4 → 3.2.5
Remington Steed (rjs7) wrote :

With Dan Wells's help, here's a signoff branch with one new commit to fix another console error (in the combo box directive itself):

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/lp1793196-vol-edit-marc-cn

Also, we found a problem with how the dropdown handles filtering of choices as you type. I'll open a new bug for that.

tags: added: signedoff
tags: removed: signedoff
Dan Wells (dbw2) wrote :

Pushed to master through rel_3_1. Thanks, Garry, Bill, and Remington!

Changed in evergreen:
milestone: 3.2.5 → 3.3-rc
assignee: Dan Wells (dbw2) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers