Deleted items showing on holds shelf

Bug #1792621 reported by Steve Callender on 2018-09-14
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.1
High
Unassigned

Bug Description

This may of been introduced with 3.0.11 and 3.1.5

Items that were deleted while on the hold shelf (had a status of 8) are now showing up on the hold shelf list. The shelf list should exclude deleted items.

I should add that this is in the web client. eg/staff/circ/holds/shelf

Mike Rylander (mrylander) wrote :

I have a branch here that fixes this issue. It also addresses an adjacent hold status calculation issue.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/miker/lp-1792621-deleted-items-on-hold-shelf

tags: added: holds pullrequest webstaffclient
Changed in evergreen:
status: New → Confirmed
importance: Undecided → High
milestone: none → 3.2-rc
no longer affects: evergreen/3.0
no longer affects: evergreen/3.1
Mike Rylander (mrylander) wrote :

I've pushed a second commit to the above branch that addresses a think-o in the hold shelf delay YAOUS test.

Changed in evergreen:
milestone: 3.2-rc → 3.2.1
Changed in evergreen:
milestone: 3.2.1 → 3.2.2
Rogan Hamby (rogan-hamby) wrote :

Signoff pushed to :

user/rogan/lp1792621_deleted_items_on_shelf

Galen Charlton (gmc) on 2018-11-05
tags: added: signedoff
Ben Shum (bshum) wrote :

Pushed to master and backported to rel_3_2. It did not backport cleanly to rel_3_1, not sure if this is something that can be easily pushed back (or is even necessary?)

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
Galen Charlton (gmc) wrote :

Adding 3.1.x target since bug 1712854 is to be backported.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers