Web Client Hourly Loan Checkin Time Wrong

Bug #1791340 reported by Joan Kranich on 2018-09-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Medium
Unassigned
3.1
Medium
Unassigned

Bug Description

Evergreen 3.0.8
Browsers Chrome and Firefox
Not a problem in the XUL Client

In the Web Client checking in an item with an hourly due date on the same day the item is due results in the Checkin Time becoming the Due Date of the item. This occurs with items not yet due when checked in and with items that are overdue. If an overdue item is checked in the overdue fines are cleared as if no fines were assessed.

Steps:

Check out an item with an hourly loan period.
Check in the item on the same day it is due.
The Checkin Scan Time is the correct check in date and time.
The Checkin Time is the due date.

Picture attached.

Revision history for this message
Joan Kranich (jkranich) wrote :
Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

We've had reports of this issue on 3.1.4.

Changed in evergreen:
status: New → Confirmed
Dan Wells (dbw2) on 2018-09-21
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Revision history for this message
Dan Wells (dbw2) wrote :

A simple fix for this is now available for review here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbwells/lp1791340_webstaff_dont_always_send_backdate

See commit message for more information on the fix.

To test:
1. Set the default loan duration(s) to a few hours long.
2. Circulate an item with the default loan duration policy to any patron.
3. Immediately checkin the item, notice the checkin time is the due date, not the current time.
4. Apply patch, repeat checkout and checkin.
5. Notice the checkin time is the current time.

Dan

Changed in evergreen:
milestone: none → 3.2-rc
tags: added: pullrequest
Changed in evergreen:
assignee: Dan Wells (dbw2) → nobody
importance: Undecided → Medium
Galen Charlton (gmc) on 2018-09-21
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Works for me! Pushed to master, rel_3_1, and rel_3_0, along with a follow-up to expand a bit on the code comment. Thanks, Dan!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers