Web client: Boolean fields say "true"/"false" when XUL client used "Yes"/"No"

Bug #1788417 reported by Chris Sharp on 2018-08-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.0
Undecided
Unassigned

Bug Description

Breaking this issue from the multiple-issue bug 1743801. The XUL client used "Yes" and "No" as labels for boolean fields displayed in the client. "true" and "false" are clear to developer types but can be confusing to end users. A patch to fix this was included in Comment #9 on bug 1743801, but since it affects all boolean fields everywhere, we're separating it into its own report.

Changed in evergreen:
status: New → Incomplete
status: Incomplete → Confirmed
milestone: none → 3.1.5
Jason Stephenson (jstephenson) wrote :

I'm targeting this as a bug at 3.0 and 3.1 because it is a departure from the XUL behavior, and it is my understanding that these are considered bugs.

I've pushed a signoff branch for master and rel_3_1 here: collab/dyrcona/lp1788417-yes-no-in-grids-signoff

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dyrcona/lp1788417-yes-no-in-grids-signoff

And, one for rel_3_0 with conflict resolution here: collab/dyrcona/lp1788417-yes-no-in-grids-rel_3_0-signoff

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dyrcona/lp1788417-yes-no-in-grids-rel_3_0-signoff

I signed off instead of just pushing in case Chris Sharp or someone else also wanted to have a look.

tags: added: signedoff
Chris Sharp (chrissharp123) wrote :

Fix pushed to master, 3.0 and 3.1. Thanks to all!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers