Manage Copy Alert requires permission granted on consortium level

Bug #1783421 reported by tji@sitka.bclibraries.ca on 2018-07-24
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.1
Medium
Unassigned
3.2
Medium
Unassigned

Bug Description

Evergreen 3.0.4

If the DELETE_COPY_ALERT permission is not granted on Consortium level, clearing copy alert via clicking Manage in Copy Alert column on Item Status does not work. But it works via Copy Alert on Copy Editor.

We need the permission to be on Library level so that only the owning library can delete its copy alert.

Tina Ji
BC Libraries Coop

John Amundson (jamundson) wrote :

Confirming this is still true in 3.2.2

This isn't just limited to DELETE_COPY_ALERT, but also CREATE_COPY_ALERT and UPDATE_COPY_ALERT.

Unless these permissions are set at the Consortial level, then any changes made to through the Manage/Add Buttons/Actions are not respected. When set at the library/town level, the changes can only be made through the Copy Editor.

Changed in evergreen:
status: New → Confirmed
John Amundson (jamundson) wrote :

Additionally, temporary alerts cannot be cleared during the action associated with the alert type when permissions are not set to the consortial level. This negates the benefits that come with temporary alerts.

They can only be cleared from the Copy Editor.

James Fournie (jfournie) wrote :

Here's something that maybe might fix it? I suspect these few strategic edits to the IDL might solve it?

I have no way of testing this at the moment so it's totally, 100% untested.

https://github.com/jamesrf/Evergreen/tree/lp1783421

https://github.com/evergreen-library-system/Evergreen/commit/f0bfc9da44781061ecd068e269aebeb02ea7e1fe

(apologies this is on GitHub)

Chris Sharp (chrissharp123) wrote :

We tested this and it works. Creating a signoff branch here so another core committer can test and verify:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/lp1783421_manage_copy_alert_perms

tags: added: permissions pullrequest signedoff
Changed in evergreen:
milestone: none → 3.next
importance: Undecided → Medium
James Fournie (jfournie) wrote :

Thanks Chris!

Changed in evergreen:
assignee: nobody → John Amundson (jamundson)
John Amundson (jamundson) wrote :

Thanks, James and Chris. I've given this a look,too, and it seems to work like a charm!

I have tested this code and consent to signing off on it with my name, John Amundson and my email address, <email address hidden>.

Since this is a bug fix, it should probably be targeted at 3.1 and 3.2, as well.

Changed in evergreen:
assignee: John Amundson (jamundson) → nobody
Changed in evergreen:
milestone: 3.next → 3.3-beta1
status: Confirmed → Fix Committed
Jason Stephenson (jstephenson) wrote :

I concur with John's assessment that this is a bug and should be backported.

I have pushed the fix to master, rel_3_2, and rel_3_1.

Thanks, James, Chris, and John!

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers