Web Client: Patron Bills - Checking One Bill Checks Them All

Bug #1780283 reported by John Amundson on 2018-07-05
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned
3.3
Undecided
Unassigned

Bug Description

Evergreen 3.0.8
Tested behavior in Google Chrome and Mozilla Firefox.
Affects all patron bills screens - current, historical, and historical payments.

If Bill #, (or Payment ID for historical payment screen), is not a displayed column, checking rows does not work correctly. Checking one bill will check all the bills. There is no way to select a single bill.

This workflow can be followed to duplicate this issue:

1. Open up a patron's Bills tab. Check/uncheck bills to confirm everything is working properly.
2. Remove the Bill # column.
3. Check one bill. All bills will check. Unchecking a bill unchecks them all.

If the Bill # column has already been removed, the workflow is slightly different:

1. Open up a patron's Bills tab. Check/uncheck bills to confirm everything is working properly.
2. Do some form of action to the bills. This includes but may not be limited to making a payment or clicking a header to sort a column.
3. Check one bill. All bills will check. Unchecking a bill unchecks them all.

This may be difficult to visualize. I've attached a gif so you can see it in action.

In both cases, adding the Bill # column back to the screen fixes the issue.

John Amundson (jamundson) wrote :
Garry Collum (gcollum) on 2018-07-05
Changed in evergreen:
status: New → Confirmed
Changed in evergreen:
assignee: nobody → John Amundson (jamundson)
John Amundson (jamundson) wrote :

The patch on bug #1776917 fixes this issue on the Bills, Current screen.

Bills, History (Bill #) and Payment, History (Payment ID) are still an issue.

Changed in evergreen:
assignee: John Amundson (jamundson) → nobody
Michele Morgan (mmorgan) wrote :

On our 3.2.4 system, I am seeing this issue only on the Bill History Payments screen.

On Current Bills and Bill History Transactions, I am able to select a single row in each of those tables.

John Amundson (jamundson) wrote :

I am still seeing this on 3.2.4 in both Bill History and Payment History. As soon as I remove the Bill #/Payment ID column, I cannot individually select rows anymore.

Dan Briem (dbriem) wrote :

Seeing this on 3.2.7 for Patron Bill History. If the Bill #/Payment ID are not visible, the unique ID for the ng-repeat is undefined, so when you select one row it selects the undefined rows (which is all of them). This patch adds the required attribute to those eg-grid-field directives. https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbriem/lp1780283_checking_1_bill_checks_all

tags: added: pullrequest
Michele Morgan (mmorgan) on 2019-08-26
Changed in evergreen:
milestone: none → 3.3.4
Changed in evergreen:
milestone: 3.3.4 → 3.3.5

Thanks for marking my other ticket a duplicate of this John, the fix from Dan Briem works for us.

Signoff branch at: user/stompro/lp1780283_checking_1_bill_checks_all_signoff

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/stompro/lp1780283_checking_1_bill_checks_all_signoff

Josh

tags: added: signedoff
Changed in evergreen:
milestone: 3.3.5 → 3.4.2
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_4, and rel_3_2. Thanks, Dan and Josh!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers