Copy note "Public Note" checkbox doesn't stay checked until saved

Bug #1778571 reported by Remington Steed on 2018-06-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.2
Medium
Unassigned

Bug Description

In the web client, when creating or editing a copy note, the "Public Note" checkbox doesn't stay checked if you close and re-open the modal window.

But if you check the box, click "OK", then click "Save & Exit" on the copy editor, it will save the "Public Note" value.

Garry Collum (gcollum) on 2018-06-25
Changed in evergreen:
status: New → Confirmed
Meg Stroup (mstroup) wrote :

Can confirm the behavior described in the description and also that the workaround will result in the note displaying.

Remington Steed (rjs7) on 2018-10-23
summary: - Copy "Public Note" checkbox doesn't stay checked until saved
+ Copy note "Public Note" checkbox doesn't stay checked until saved
Remington Steed (rjs7) wrote :

Also, when attempting to change a public note back to private (by unchecking "Public Note", clicking "OK", then clicking "Save & Exit"), the change doesn't save. I mention this in case it gives clues to the cause of the other problem. But if unrelated, it can become a separate bug report.

Remington Steed (rjs7) wrote :

Found the solution to both. Branch coming first thing tomorrow.

Remington Steed (rjs7) wrote :

Or actually, make that "first thing Thursday".

Remington Steed (rjs7) wrote :

Here's the branch:
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/lp1778571_copy_note_public_flag_fix

Steps for testing are in the commit message. Note that clearing the browser cache is required to fully test the fix.

tags: added: pullrequest
Changed in evergreen:
importance: Undecided → Medium
milestone: none → 3.2.2
Changed in evergreen:
milestone: 3.2.2 → 3.2.3
Changed in evergreen:
milestone: 3.2.3 → 3.3-beta1
Changed in evergreen:
milestone: 3.3-beta1 → 3.3-rc
Michele Morgan (mmorgan) wrote :

This fix works exactly as Remington describes based on the excellent testing notes included in the commit. My signoff branch is here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=9ca946f5e9b8cd225592a58648c63584edeefe8b

tags: added: signedoff
Chris Sharp (chrissharp123) wrote :

Pushed to master and rel_3_2. Thanks, Remington and Michele!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers