The catalog menu should include Item Status

Bug #1778414 reported by Jane Sandberg on 2018-06-24
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

The Web client includes Item Status in the Circulation menu. It also is in the Search menu, but it's not called Item Status there. Catalogers use Item Status all the time, so I propose that there also be an Item Status menu item in the Cataloging menu. I also propose that -- unlike in the XUL client, where it is called "Display Item" -- it be called "Item Status" to improve consistency.

Garry Collum (gcollum) wrote :

A proposed patch is here. http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=615cb9a7b72dd70b8fa0250b8c8f81c6640923dd

It adds Item Status under Search the Catalog in the Catalog menu and separates the two 'search' options from the bucket options.

tags: added: pullrequest
Kathy Lussier (klussier) wrote :

Before this feature goes in, I would like to point to the previous discussion we had on bug 1528912 where we discussed adding the Replace Barcode option to both the Circulation and Cataloging menus. There was an opinion at the time that reducing duplicate menu entries would be one way to meet the goal of reducing clutter in the web client.

I'll point out that I was one of the people who voiced support for the action being available in both places, but I also would like to see us handling these decisions consistently. If we decide it's of value to add another menu entry for Item Status, then should we review other menu actions to see if there are others, like Replace Barcode, that should be available in more places? Alternatively, if we decided on the previous bug that the one menu entry is sufficient for Replace Barcode, maybe we should try to reduce the number of menu entries for Item Status as well to make it easier for training staff.

Maybe it would be worth having a larger community discussion about what approach should be used in then document it in some form of a UI style guide.

Garry Collum (gcollum) wrote :

Thanks Kathy for pointing us to the previous conversation. I'm torn between getting rid of clutter and adding menu options where different users expect the options to be. I personally would rather get rid of all the duplicates and have less clutter. I like simple, but I also have to listen to my users who have expressed the desire for duplicate menu options.

I also think we should have a UI style guide, that includes issues like this and also includes a set of controlled vocabulary for things like the 'item vs. copy' debate.

Jane Sandberg (sandbej) wrote :

I agree about reducing clutter. I've always thought of Item Status as being pretty useful for circ folks, but essential for catalogers, though. What would people think about removing it from the Circ menu, and adding it to the Cataloging menu?

Remington Steed (rjs7) on 2018-11-09
Changed in evergreen:
status: New → Confirmed
Jane Sandberg (sandbej) wrote :

Adding needsdiscussion tag, since I think that we need to have a larger conversation outside of Launchpad to help us out here.

tags: added: needsdiscussion
Meg Stroup (mstroup) wrote :

Tested on 5/22/2019. Item status appears in cataloging drop-down menu (as well as in circulation menu-- needsdiscussion tag likely still applies).

I have tested this code and consent to signing off on it with my name, Meg Stroup, and my email address, <email address hidden>.

Attached screenshot for verification.

Changed in evergreen:
assignee: nobody → Meg Stroup (mstroup)
tags: added: signedoff
Galen Charlton (gmc) wrote :

This was discussed during today's development meeting:

http://irc.evergreen-ils.org/evergreen/2019-06-04#i_408331

Upshot: there's a rough agreement to duplicate the Item Status menu item and to adopt something along these lines as a design principle: "Menus in the Evergreen staff interface serve as entry points to the functionality most used by various classes of library staff, and as such, duplication of menu items between menus is permitted provided that the same page/function has the same name in each copy."

Galen Charlton (gmc) on 2019-07-31
Changed in evergreen:
assignee: Meg Stroup (mstroup) → nobody
importance: Undecided → Wishlist
milestone: none → 3.4-beta1
Galen Charlton (gmc) wrote :

Following up, I've pushed this change to master for inclusion in 3.4. I've also pushed a follow-up adding the menu item to the Angular version of the menus. Thanks, Garry and Meg!

Changed in evergreen:
status: Confirmed → Fix Committed
Galen Charlton (gmc) on 2019-09-11
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers