Web Client: Location Missing from Item Out

Bug #1778083 reported by Scott Thomas
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.1
Medium
Unassigned

Bug Description

In the Web Client, "Location" (i.e. Copy Shelving Location) does not appear as a column choice in Items Out. It is available in XUL.

Beth Willis (willis-a)
Changed in evergreen:
status: New → Confirmed
Revision history for this message
Beth Willis (willis-a) wrote :

It appears that some other options are also missing from the "Items Out" interface. These include: Acquisition cost, Is Floating, Age Based Hold Protection.

Additionally, Last Edit Date/Time and Record Creation Date/Time display twice in the column picker. In both cases, it looks as though one option refers to the copy and the other to the bib record. These labels should distinguish between the two.

EG 3.0.7

Revision history for this message
Garry Collum (gcollum) wrote :

A proposed patch is at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gcollum/lp1778083-location-missing-from-items-out

The patch adds Location, Floating Group, and Age-based Hold Protection as column options to the items out grid. I made them hidden by default.

The other fields mentioned in this bug, Edit Date/Time, Record Creation Date/Time, and Acquisition Cost (which actually appears as an option as 'Cost') are pulled into the list of options via a wild card character. These columns are more related to bug #1735808. https://bugs.launchpad.net/evergreen/+bug/1735808

tags: added: pullrequest
Revision history for this message
Scott Thomas (scott-thomas-9) wrote :

The patch is much appreciated. Can someone explain what is meant by "wild card character." I know what the phrase means, but not in the context of a column picker.

Thank you,
Scott

Revision history for this message
Garry Collum (gcollum) wrote :

Hi Scott,

Wildcard character may just be my term. In the grid definitions there are lines with asterisks like the one below.

<eg-grid-field path="target_copy.*" hidden></eg-grid-field>

Instead of defining each field in the drop-down individually, this line pulls definitions for the copy options from the field mapper.

Revision history for this message
Scott Thomas (scott-thomas-9) wrote :

Garry,
  So....this is not something I can do in the staff client. Is this correct?

Scott

Revision history for this message
Garry Collum (gcollum) wrote :

Scott,

I'm not sure what you mean by 'this' but it sounds incorrect.

My patch brings in columns from linked tables to which the original code was not making references.

What it doesn't do is rename some labels in the drop-down list, such as Cost, and Last Edit Date/Time, which are already available in the list. This can easily be done if the fields are individually defined in the code, instead of brought in by a wild card. That's what bug #1735808 is about.

When this is done we need to get community support on which columns need to be in the drop-downs and which do not, and there's a sorting issue that needs to be resolved.

But if there are columns that are missing that are needed by staff, I think that's more important than the sorting issue. IMO.

Changed in evergreen:
assignee: nobody → Jennifer Pringle (jpringle-u)
Revision history for this message
Dawn Dale (ddale) wrote :

I am testing this patch.

Changed in evergreen:
assignee: Jennifer Pringle (jpringle-u) → Dawn Dale (ddale)
Revision history for this message
Dawn Dale (ddale) wrote :

I have tested this code and consent to signing off on it with my name, Dawn Dale and my email address, <email address hidden>

Changed in evergreen:
assignee: Dawn Dale (ddale) → nobody
tags: added: signedoff
Galen Charlton (gmc)
Changed in evergreen:
milestone: none → 3.2.1
importance: Undecided → Critical
importance: Critical → Medium
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_2, and rel_3_1. Thanks, Garry and Dawn!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Looks like the 3.1 milestone may have been missed for this bug. It's currently pointing at 3.2.1 twice

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers