Comment 14 for bug 1777675

Dan Wells (dbw2) wrote :

I've learned to love incremental improvements, and think this proposal sounds fine. My only suggestion would be to give the table a suitably specific name to leave room for the fuller and more general future table(s). Think something like Mike's "asset.last_copy_inventory" rather than "asset.inventory", etc. Eventually going from single to multi-entry (which I support) will be a different shape for reporting reasons, so we won't really be able to extend the proposed table and keep reporting compatibility. We would instead at that point be talking about turning the existing table into a view over the expanded table, so perhaps we can save ourselves from awkward naming mismatches down the road and give it the view-like name today.

My two cents.