Stat cat entries not in alphabetical order

Bug #1777184 reported by Remington Steed on 2018-06-15
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

In the web client, the entries within each statistical category dropdown are not in sorted alphabetically. However, they were sorted in the XUL client.

Remington Steed (rjs7) on 2018-06-15
tags: added: sorting
Remington Steed (rjs7) wrote :

I'm guessing we need to add an order_by to the pcrud.search call in the service.get_statcats function within Open-ILS/web/js/ui/default/staff/cat/volcopy/app.js.

Changed in evergreen:
status: New → Confirmed
tags: added: statcats webstaffclient
Changed in evergreen:
assignee: nobody → Jason Etheridge (phasefx)
Suzanne Paterno (paterno) wrote :

I updated the search to sort first by library, then by statistical category, then sort entires within the categories.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=8e30427717b1f48acc3a8c8e95c0698bc4400adc

Jason Etheridge (phasefx) wrote :

Is alphabetical sorting enough or does some consideration of the library owning the entry need to be made as well (and should those be exposed like they are for the actual stat cats)? It could arguably be a bad configuration to have identically labeled but differently owned entries show up for a given stat cat, but there's nothing stopping it. Is there a legitimate use case for that?

Jason Etheridge (phasefx) wrote :

Ha, I totally didn't see Suzanne's addition when I added my comment. I'll relinquish self-assignment of this bug for now.

Suzanne, in your patch, you shouldn't need to try to flesh the value field for the entry objects.

Changed in evergreen:
assignee: Jason Etheridge (phasefx) → nobody
Jason Etheridge (phasefx) wrote :

Incidentally, the patch does work as written (and so does a more modest form I was trying with sorting just the entries, since we have client-side sorting now of the stat cats themselves thanks to Jane).

Jason Etheridge (phasefx) wrote :

Suzanne, I pushed a working branch with a tweak to your changes. Could you test and add your Sign-Off to the commit? Thanks!

collab/phasefx/lp1777184 @ working/Evergreen.git

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/phasefx/lp1777184

Cesar V (cesardv) wrote :

I tested Jason's branch and it seems to organize the stat cats by org. unit name alphabetically, and within the stat cat entries. I've pushed a signoff branch here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/cesardv/phasefx_lp1777184_signoff

Suzanne, if Jason's tweak works for you, I can go ahead and push it to master

Suzanne Paterno (paterno) wrote :

Cesar I am fine with putting in Jason's change. As long as it sorts I don't care how it's coded :)

Michele Morgan (mmorgan) on 2019-05-09
tags: added: pullrequest
Michele Morgan (mmorgan) on 2019-05-09
Changed in evergreen:
milestone: none → 3.4-beta1
Michele Morgan (mmorgan) wrote :

Added tags and targets. The branch has two signoffs. Cesar, I'd say you can go ahead and push it to master.

tags: added: signedoff
Galen Charlton (gmc) on 2019-05-23
Changed in evergreen:
milestone: 3.4-beta1 → 3.3.2
no longer affects: evergreen/3.3
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

I've pushed this to master, rel_3_3, rel_3_2, and rel_3_1. Thanks, Suzanne, Jason, and Cesar!

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers