Columns don't save on patron's Group Member Details grid

Bug #1774707 reported by Remington Steed on 2018-06-01
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

Column picker configuration doesn't save for the Group Member Details grid within a patron's record.

Similar to the fix for bug 1721145, we probably just need an appropriately named persist-key in circ/patron/t_group.tt2 .

Jane Sandberg (sandbej) on 2018-06-05
tags: added: webstaffcolumns
John Amundson (jamundson) wrote :

Confirmed this is occurring in Web Client 3.0.8.
Tested in Google Chrome.

Changed in evergreen:
status: New → Confirmed
Remington Steed (rjs7) on 2018-11-05
Changed in evergreen:
assignee: nobody → Remington Steed (rjs7)
Remington Steed (rjs7) wrote :
Changed in evergreen:
assignee: Remington Steed (rjs7) → nobody
tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.2.2
Remington Steed (rjs7) wrote :

Note: to test, you will probably need to clear your browser cache.

Changed in evergreen:
milestone: 3.2.2 → 3.2.3
Remington Steed (rjs7) wrote :

This needs an upgrade script (add this persist key to config.workstation_setting_type) because of the change to server-side settings. Thanks to Michele Morgan for the tip (see https://bugs.launchpad.net/evergreen/+bug/1729435/comments/5).

tags: added: needsrepatch
removed: pullrequest
Changed in evergreen:
milestone: 3.2.3 → 3.3-beta1
Changed in evergreen:
milestone: 3.3-beta1 → 3.3-rc
Changed in evergreen:
milestone: 3.3-rc → 3.3.1
Michele Morgan (mmorgan) on 2019-04-12
Changed in evergreen:
assignee: nobody → Michele Morgan (mmorgan)
Michele Morgan (mmorgan) wrote :
tags: added: pullrequest
removed: needsrepatch
Changed in evergreen:
assignee: Michele Morgan (mmorgan) → nobody
Bill Erickson (berick) on 2019-05-20
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Issue and fixes confirmed. Thanks Michele and Remington. Merged to 3.2 and above.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 3.3.1 → 3.3.2
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers