Webstaff: Webpack dependency ajv missing warning after npm install

Bug #1771613 reported by Cesar V on 2018-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Looks like there's some dependency wierdness with AJV (a json validator).
Currently when installing from the latest working master (after the pinning of AngularJs to @~1.6.x) I get a warning: ERR! peer dep missing: ajv@^6.0.0, required by ajv-keywords@3.1.0

Looks like webpack (resolved to v3.12) depends on ajv@^6.1.0 and ajv-keywords@^3.1.0, at the same time ajv-keywords depends on @ajv@^6.0.0 -- which is fine and would mean that the latest x in ajv@6.x would get installed but that doesn't seem to be happening for some reason, and thus we get the warning.

I poked at this for a bit but not being versed how to resolve these dependency shenanigans, I figure I'll go ahead and report it.

The webstaff still works fine, however, as AJV is a webpack dependency for something that apparently we're not needing/using at the moment.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers