Default installations of Evergreen should have UPC Z39.50 search for OCLC and LoC

Bug #1768902 reported by Jane Sandberg on 2018-05-03
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Out of the box, the Z39.50 UPC search works for searching the local catalog, but not OCLC and LoC.

Here is the attribute definition I added for OCLC:
Name: upc
Label: UPC
Code: 1007
Format: 6
Truncation: 0

Here is the loc one I added:
Name: upc
Label: UPC
Code: 1007
Format: 1
Truncation: 1

It would be great to have these running out of the box -- they are so helpful for cataloging DVDs. :-D

Ben Shum (bshum) wrote :

This is a quick working branch that adds the code to the table. I also included a very brief release note in the Docs side, that might need to be modified further.

Working branch: user/bshum/lp1768902-add-upc-to-z3950

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/lp1768902-add-upc-to-z3950

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.2-beta
status: New → Confirmed
importance: Undecided → Wishlist
Garry Collum (gcollum) wrote :

Hi Ben,

It looks like you have a couple of typos.

In "XXXX.data.add-upc-to-z3950.sql" there's a semi-colon right before the WHERE clause in the second INSERT statement.

In "950.data.seed-values.sql" the values for the second insert are ("20", "loc", instead of "20", "oclc".

Ben Shum (bshum) wrote :

Oops, thanks for the eyes on that Garry! This is what happens when I'm poking at things in the lobby post-conference instead of getting a real lunch :)

Fixed the issues in the files and force pushed a new rebased version to the same branch name in working repo.

Garry Collum (gcollum) wrote :

Thanks Ben. I applied the upgrade sql script to my database and the UPC search for both loc and oclc worked perfectly. Dropped my database and re-created it using your branch and the UPC search also worked perfectly.

Sign-off branch at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gcollum/lp1768902-add-upc-to-z3950-signoff

tags: added: signedoff
Jane Sandberg (sandbej) on 2018-08-23
tags: added: needsreleasenote
Ben Shum (bshum) wrote :

My branch has a release note in it. Looks like Garry didn't pick it into his branch.

tags: removed: needsreleasenote
Jane Sandberg (sandbej) wrote :

Sorry about that, Ben! I knew I'd seen release notes somewhere. Garry, would you mind bringing Ben's release notes into your sign-off branch to keep everything in one place?

Thanks to both of you! I think it will make a lot of catalogers very happy. :-)

Bill Erickson (berick) on 2018-08-24
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Thanks, all. I picked the sign-off commit and release notes into master (plus DB upgrade stamp).

Changed in evergreen:
status: Confirmed → Incomplete
status: Incomplete → Fix Committed
assignee: Bill Erickson (berick) → nobody
Garry Collum (gcollum) wrote :

Thanks Bill.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers