webclient: undelete is subject to weird possibly caching-related issues

Bug #1768122 reported by Andrea Neiman on 2018-04-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Web client 3.0.7

If I undelete a previously deleted record, it still will show as deleted in the OPAC view. If I add copies to the undeleted record, these copies are also not visible in the OPAC view.

However, I couldn't reproduce this totally reliably -- sometimes after a refresh, the undeleted record would behave as expected and other times after a refresh it would be demonstrating the problems noted above. Nothing weird in the console, so I wonder if some kind of cache issue is to blame.

I realize this isn't the most helpful bug report but I was seeing it consistently enough that I thought it was worth a mention to see if anyone else was experiencing the same thing.

Remington Steed (rjs7) on 2018-05-09
summary: - webclient: undelete subject to weird possibly caching-related issues
+ webclient: undelete is subject to weird possibly caching-related issues
Mary Llewellyn (mllewell) wrote :

I ran into it last night. I undeleted a record in the web client, but could not clear the "deleted" labeling in the OPAC view. I tried searching for the Record ID in a new tab, but got the same "deleted" message.

I'll add more the next time I run into this.

Andrea Neiman (aneiman) wrote :

Possibly related to bug 1778314 ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers