Web Client: Patron Search Screen - Permission Grp Dropdown lacks scroll bar

Bug #1766712 reported by Jeanette Lundgren on 2018-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.0
Undecided
Unassigned

Bug Description

In the patron search screen, the home library drop down opens smaller with a scrollbar and the permission group field expands in full without scroll bar.

We would like the permission group field to open like the home library field with a scroll bar.

CW MARS has a lot of permission groups and navigation is problematic without a scrollbar, especially on mobile devices.

See related bug for patron edit screen: https://bugs.launchpad.net/evergreen/+bug/1721143

Jane Sandberg (sandbej) wrote :

I created a branch for this here, Jeanette: user/sandbergja/lp1766712_add_scrollbar_to_patron_search_permission_group_field

Here's a link: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1766712_add_scrollbar_to_patron_search_permission_group_field

tags: added: pullrequest
Changed in evergreen:
status: New → Confirmed
milestone: none → 3.2-beta
assignee: nobody → Jason Stephenson (jstephenson)
Jeanette Lundgren (jlundgren) wrote :

Thanks Jane! Tested on 3.0.7

I have tested this code and consent to signing off on it with my name, Jeanette Lundgren and my email address, <email address hidden>.

tags: added: signedoff
Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
Jason Stephenson (jstephenson) wrote :

The branch works for me also.

Pushed to master, rel_3_1, and rel_3_0.

Thanks, Jane and Jeanette!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
milestone: 3.2-beta → 3.1.2
no longer affects: evergreen/3.1
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers