Web Client: STAGING_USER_STAGE_NOT_FOUND

Bug #1765179 reported by Scott Thomas on 2018-04-18
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.1
Medium
Unassigned
3.2
Medium
Unassigned

Bug Description

If a patron goes into self-registration feature in the catalog and self-registers and then a staff member goes into Pending Patrons in the Web Client, fills in required fields, and clicks on Save, they will receive a STAGING_USER_STAGE_NOT_FOUND error. The record is saved, but, needless to say, the error can be an annoyance.

Scott

Here is the error message that appears . . . (screenshot attached)

Changed in evergreen:
status: New → Confirmed
Meg Stroup (mstroup) wrote :

Confirmed in Evergreen 3.1.6.

You load a patron from the pending queue, make any necessary changes, and save. The staging error (screenshot attached) then appears, which gives the impression that the action was unsuccessful (the screen reverts to a new register patron screen).

However, when you search for the patron, you see that the card was created successfully, and they're no longer in the pending patrons queue.

Cesar V (cesardv) on 2018-12-10
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :

Here's a patch that addresses the error alert/message and the pending patron grid refresh a user has been fully registered an is no longer pending. Issue was that after completing a staged user registration, the controller in regctl.js was refreshing to the same route, and trying to fetch the same staged user, but never finding it as it was no longer a staged/pending user.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1765179_pending_user_fixes

tags: added: pullrequest
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Jason Etheridge (phasefx) wrote :

Works for me; pushed to master. Thanks Cesar!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
milestone: none → 3.next
Jason Etheridge (phasefx) wrote :

also pushed to rel_3_2

Changed in evergreen:
milestone: 3.next → 3.2.3
milestone: 3.2.3 → 3.next
Andrea Neiman (aneiman) on 2019-01-09
Changed in evergreen:
importance: Undecided → Medium
Changed in evergreen:
milestone: 3.next → 3.3-beta1
status: Fix Committed → Fix Released
Changed in evergreen:
status: Fix Released → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers