Item Status Detail View: Holdable field displays OPAC Visible value

Bug #1760662 reported by Jason Boyer on 2018-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.0
High
Unassigned
3.1
High
Unassigned

Bug Description

Eg 3.0+, 3.1+, master - as of 2018-04-02

The Summary tab of the Item Status Detail View shows the wrong value for the Holdable field; rather than the value of the holdable field it's displaying the value of opac_visible. A quick fix approaches.

Jason Boyer (jboyer) wrote :
tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0.7
milestone: 3.0.7 → none
Jason Stephenson (jstephenson) wrote :

CW MARS haven't confirmed this bug, yet, but we see behavior that appear to be consistent with the description.

We're testing the patch on 3.0.6 and we will confirm the bug if we're able to determine that this is indeed why some non-holdable items are showing up as holdable for us.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
status: New → Confirmed
importance: Undecided → High
milestone: none → 3.next
tags: added: signedoff
Jason Stephenson (jstephenson) wrote :

I have confirmed the initial bug and tested the patch. It works with a follow up commit to remove the boolText filter that is apparently not needed here, since the copy holdable field is converted to a boolean on the way to the screen.

Sign off branch is here: user/dyrcona/lp1760662_item_status_summary_holdable-signoff

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1760662_item_status_summary_holdable-signoff

Dan Wells (dbw2) on 2018-04-17
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

Works; pushed to master through rel_3_0. Thank you, Jasons!

Changed in evergreen:
assignee: Dan Wells (dbw2) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers