Make Annotate on Bill Pay Screen Sticky

Bug #1759343 reported by Robert J Jackson
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
3.1
Low
Unassigned
3.2
Low
Unassigned

Bug Description

web client 3.0.5

Legacy staff client remembers the setting of the Annotate field (on or off) in the bill payment screen.

Staff would like the ability to once again set the Annotate as selected and have it remain from session to session.

Kathy Lussier (klussier)
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Jason Boyer (jboyer) wrote :

Here's a branch that makes the Annotate option on the Bills page a persistent workstation setting.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1759343_sticky_annotate / working/user/jboyer/lp1759343_sticky_annotate

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.next
Jason Boyer (jboyer)
Changed in evergreen:
milestone: 3.next → 3.3-beta1
Revision history for this message
Terran McCanna (tmccanna) wrote :

We tested this on 3.2.3 and it works well, thanks Jason!

I have tested this code and consent to signing off on it with my name, Terran McCanna, and my email address, <email address hidden>.

tags: added: signedoff
no longer affects: evergreen/3.2
Changed in evergreen:
milestone: 3.3-beta1 → 3.3-rc
Changed in evergreen:
milestone: 3.3-rc → 3.3.1
Andrea Neiman (aneiman)
tags: added: ws-settings
Changed in evergreen:
milestone: 3.3.1 → 3.3.2
Jane Sandberg (sandbej)
Changed in evergreen:
assignee: nobody → Jane Sandberg (sandbej)
Revision history for this message
Jane Sandberg (sandbej) wrote :

Pushed to master, rel_3_3, rel_3_2, and rel_3_1. Thanks so much, Jason and Terran.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Jane Sandberg (sandbej) → nobody
Revision history for this message
Jason Stephenson (jstephenson) wrote :

It turns out that the supplied branch does not work with Evergreen 3.1 and needs to be backed out. The rel_3_1 branch will require a different fix.

Revision history for this message
Dan Wells (dbw2) wrote :

We've been attempting to release the last couple days, and in trying to sort out the 3.1 breakage noted by Jason above, I noticed what I believe is another bug in this code as committed. The setting as added to the DB does not match the setting as used in the code, as one is prefixed with 'eg.' and the other is not. I think in this case we are better off changing the code to match the DB, rather than deal with more DB trouble. It is a fairly small thing, but releases should probably be re-rolled for 3.2 and 3.3 as well.

Branch incoming...

Changed in evergreen:
status: Fix Committed → Confirmed
Revision history for this message
Dan Wells (dbw2) wrote :

Okay, branch is here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbwells/lp1759343_cleanup

working/user/dbwells/lp1759343_cleanup

It is *two* commits. One to add the prefix to the code, and a second to fix a missing DB translation function.

I am going to commit Dyrcona's 3.1 branch changes to rel_3_1 right now, so please make sure these commits come after that :)

Revision history for this message
Dan Wells (dbw2) wrote :

Okay, I have pushed Dyrcona's (aka Jason's) rel_3_1 reverts to rel_3_1. Thanks, Jason!

Finally, if it wasn't yet obvious, the DB commit in my branch is for master through rel_3_2 only; it won't apply to rel_3_1. The first commit, however, should be fully backported through 3.1.

Revision history for this message
Chris Sharp (chrissharp123) wrote :

Okay, pushed Dan's latest fixes to 3.1 (just the first commit, as requested), 3.2, 3.3, and master. Thanks to all!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers