Deprecate i18n building for XUL client

Bug #1757455 reported by Chris Sharp on 2018-03-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Right now, our building process for i18n requires string translation for our XUL client. Unfortunately for us, the version of translate-toolkit on Ubuntu 16.04 (and similar-vintage Debian, probably) assumes a newer version of XUL than our ancient one and those tools no longer work for that. Since we are deprecating the XUL client altogether, we should remove XUL strings from our i18n files.

Ben Shum (bshum) on 2018-05-03
tags: added: i18n removexul
Changed in evergreen:
status: New → Confirmed
Ben Shum (bshum) wrote :

Working branch: user/bshum/remove-xul-i18n

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/remove-xul-i18n

This branch removes the makefile targets of dtds2pot and props2pot from the newpot target. This means that future newpot runs to get new translation template changes will skip over the dtds and property files.

The original XUL client translation files will still exist and can still be translated for the time being. We will just no longer compare them to update changes for XUL client (which shouldn't be changing anyways).

Pullrequest tagged for next Evergreen release.

Changed in evergreen:
milestone: none → 3.next
importance: Undecided → Medium
tags: added: pullrequest
Galen Charlton (gmc) on 2018-11-05
Changed in evergreen:
milestone: 3.next → 3.3-beta1
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Tested and signed off. Branch is user/gmcharlt/lp1757455_signoff

tags: added: signedoff
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Galen Charlton (gmc) wrote :

As a week has passed, I've gone ahead and pushed this to master. Thanks, Ben!

Changed in evergreen:
status: Confirmed → Fix Committed
Ben Shum (bshum) wrote :

Needs a quick followup to repair a problem with i18n installation.

With the make LOCALE=xx-YY install (install target), it was calling updatepo and then trying to copy files for XUL that no longer were being generated due to the changes here.

Followup commit: user/bshum/lp1757455-followup

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/lp1757455-followup

Changed in evergreen:
status: Fix Committed → In Progress
Galen Charlton (gmc) wrote :

Pushed the follow-up to master. Thanks, Ben!

Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
status: In Progress → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers