egBasicComboBox drop-down not working

Bug #1756110 reported by Galen Charlton on 2018-03-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.12
Medium
Unassigned
3.0
Medium
Unassigned

Bug Description

The template for egBasicComboBox includes an outdated reference to the Bootstrap dropdown directive. Consequently, clicking the button to activate the drop-down causes nothing to happen.

Places affected include:

- The change operator action in the report template editor
- The part selector in the volume/copy editor
- Template selector in the volume/copy editor
- Template selector in the labels interface
- Routing label selector in the subscription manager
- Call number prefix and suffix selectors in the serials batch receiving interface

Since I ran into this only recently, I assume that recent dependency or Angular updates made the issue visible; regardless, the patch that I'm about to write should be backportable all the way to 2.12.x.

Evergreen master

Galen Charlton (gmc) on 2018-03-15
Changed in evergreen:
milestone: none → 3.0.5
Galen Charlton (gmc) wrote :
tags: added: pullrequest
Kathy Lussier (klussier) on 2018-03-20
Changed in evergreen:
status: New → Confirmed
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

Thanks Galen! It works for me in master, and I've merged the fix there. However, I'm getting a conflict in 3.0 and wasn't sure how to handle it.

In master, commit 6f1f2a4faf added uib-dropdown to the two lines preceding the line you changed in your patch. Those changes weren't made to 3.0 and 2.12, and I don't know if we should be backporting the changes made to those lines or not.

Changed in evergreen:
milestone: 3.0.5 → 3.1-rc
assignee: Kathy Lussier (klussier) → nobody
status: Confirmed → Fix Committed
Galen Charlton (gmc) wrote :

Thanks, Kathy. To answer your question, the "dropdown" attributes you're referring to should also be changed to "uib-dropdown" when you backport.

Kathy Lussier (klussier) wrote :

Thanks Galen! I verified the changes in the resolved patch didn't break the dropdowns in 3.0 and backported the patch.

There were even more conflicts for 2.12. Since the dropdowns are still working as expected in 2.12 at this time, I've opted not to backport it that far.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers