Printer List Empty In Hatch Printer Settings

Bug #1756084 reported by Robert J Jackson on 2018-03-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

web client 3.0.5

Latest Hatch version (1.5) installed on this date

latest compatible Java 64 bit version installed on this date

Machine is Windows 7 64 bit OS

Hatch installs OK and appears to be running as expected. The list of printers under "Select Printers" is empty.

Multiple machines with same configuration and this issue exists on some while not on others!

Bill Erickson (berick) wrote :

Hi Robert, could you check the contents of the extension browser console that are logged when then page is loaded and/or when navigating to the printer admin page?

If you see anything that looks like error messages, please post them here.

Docs on how to access the extension console are at the bottom of https://evergreen-ils.org/documentation/install/INSTALL_Hatch.html in the section titled "Optional: Debugging The Chrome Extension".

It might also be useful to run the Hatch test script, see "Optional: Test Hatch" in the same doc.

Robert J Jackson (rjackson) wrote :

Attached is the console that is seen on one of the effected work stations.

Bill Erickson (berick) wrote :

Thanks, Robert. This appears to be an installation issue. The browser is unable to talk to the Java service. My next suggestion would be to try the step listed in "Optional: Test Hatch" to see if the Hatch script (which runs the Java executable) runs OK.

Robert J Jackson (rjackson) wrote :

Bill, we have tried maybe 3 times re-installing hatch and when a test is performed it gives the attached error message.

Bill Erickson (berick) wrote :

Can you confirm a "lib" directory exists in the Hatch install directory and that it includes a hatch.jar file?

What happens when you run this in the install directory:

java -cp lib\* org.evergreen_ils.hatch.TestHatch

Robert J Jackson (rjackson) wrote :

Bill,

This is happening (blank printer list) on one install that does not have a lib directory (?) and another that does. Here is the results of running on the install with a lib directory and running the requested command.

Bill Erickson (berick) wrote :

Robert, for the PC with no lib directory, the installer simply failed somewhere along the way. So that's problem 1. Curious what happens if you re-run the installer.

For the PC with a lib directory, the output looks right.

When you ran your 'hatch test' command before, did you run it on one with the lib directory or without?

Robert J Jackson (rjackson) wrote :

Bill,

The command was just executed this AM and on the one with the lib directory. I think we have tried to run the install again with no luck on creating the lib directory but I will suggest that to the site to be sure.

Robert J Jackson (rjackson) wrote :

Bill,

I have the following back from the site:

I did that earlier on both (using the uninstaller and reinstalling worked on the stations that were able to see printer prior to the Sun-Mon update) but didn't do anything for the Circ stations. The screen shot was send after uninstalling/reinstalling.

So for some reason the lib directory was not created ?

John Amundson (jamundson) wrote :

Yesterday, one of our libraries reported this issue with the same "Hatch is disconnected when communicating with the native messaging host" message.

Today, the library reported they were successful in getting the printers to show. I wanted to pass along their response in case it is helpful:

"I just wanted to let you know that the problem has been resolved. I
reinstalled the software this morning and the printer still wasn't
showing. I went into the Hatch folder to see if the jars files were there
and ran the hatch.bat file. In that file was a line stating that my
graphics card was below the minimum level for running Hatch. Once I
updated the Intel graphics card, the printer showed immediately."

Web Client 2.12.6
Hatch Version 0.1.5

I am unsure of the Windows version.

Lynn Floyd (lfloyd) wrote :

Here is a windows 7 32 bit machine running Web Client 3.0.1 Hatch 0.1.5 and no printers show.

https://pastebin.com/qsvcZwDF

Here are the hatch.bat test files, and Extension Console error log.

Hatch sees the printers, but the Web Client does not.

Extension Errors out with "Access to the specified native messaging host is forbidden."

Lynn Floyd (lfloyd) on 2018-04-09
Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick) wrote :

Thanks for the details, Lynn.

There's a bit of configuration that allows Chrome to talk to the Java app. It consists of a file and a Windows registry key, telling Chrome where to find the file.

Can you confirm this file exists and that your user account can view the contents of the file?

C:\Program Files (x86)\Hatch\extension\host\org.evergreen_ils.hatch.json

Can you confirm one of these commands run within the Windows command line returns a value that references the above files?

reg query HKLM\SOFTWARE\Google\Chrome\NativeMessagingHosts /s
reg query HKLM\SOFTWARE\WOW6432Node\Google\Chrome\NativeMessagingHosts /s
reg query HKCU\SOFTWARE\Google\Chrome\NativeMessagingHosts /s
reg query HKCU\SOFTWARE\WOW6432Node\Google\Chrome\NativeMessagingHosts /s

For me, the 2nd command returns:

reg query HKLM\SOFTWARE\WOW6432Node\Google\Chrome\NativeMessagingHosts /s
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Google\Chrome\NativeMessagingHosts\org.evergreen_ils.hatch
    (Default) REG_SZ C:\Program Files (x86)\Hatch\extension\host\org.evergreen_ils.hatch.json

Lynn Floyd (lfloyd) wrote :

Here is what the Query's return ran as the user.
This is a 32 bit machine.

C:\Users\mike>reg query HKLM\SOFTWARE\Google\Chrome\NativeMessagingHosts /s

HKEY_LOCAL_MACHINE\SOFTWARE\Google\Chrome\NativeMessagingHosts\org.evergreen_ils.hatch
    (Default) REG_SZ C:\Program Files\Hatch\extension\host\org.evergreen_ils.hatch.json

C:\Users\mike>reg query HKLM\SOFTWARE\WOW6432Node\Google\Chrome\NativeMessagingHosts /s
ERROR: The system was unable to find the specified registry key or value.

C:\Users\mike>reg query HKCU\SOFTWARE\Google\Chrome\NativeMessagingHosts /s

HKEY_CURRENT_USER\SOFTWARE\Google\Chrome\NativeMessagingHosts\com.adobe.acrobat.chrome_webcapture
    (Default) REG_SZ C:\Program Files\Adobe\Acrobat Reader DC\Reader\Browser\WCChromeExtn\manifest.json

C:\Users\mike>reg query HKCU\SOFTWARE\WOW6432Node\Google\Chrome\NativeMessagingHosts /s
ERROR: The system was unable to find the specified registry key or value.

The one thing I notices is that the Native Messaging Hosts as HKCU returns Adobe acrobat here HKLM returns Hatch. I am wondering if there is conflict there?

Bill Erickson (berick) wrote :

Thanks, Lynn. And you confirmed this file exists and is readable by the user?

C:\Program Files\Hatch\extension\host\org.evergreen_ils.hatch.json

If it's readable, can you paste the contents of the file?

No worries about the Adobe vs. Hatch entries. There can be multiple entries under NativeMessagingHosts.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers